0 Replies Latest reply on Nov 16, 2015 5:37 PM by flxmmr

    UEFI-Firmware borked by using MSI Afterburner in an VM, so that VESA still works, but Catalyst dies with Code 43

    flxmmr

      Hello,

       

      I have a R9 390 by Sapphire, which I use in UEFI-Mode in my Windows 10 virtual machine (KVM with GPU passtrough on Debian Jessie) to play games . Yesterday I installed MSI Afterburner to get some in.game performance metrics and it still worked fine, but today rebooting led to a black screen after showing the UEFI and Windows Boot-Splash. RDPing into Windows it turned out, the device was disabled because of malfunction "Code 43". Suspecting Windows 10s almight update mechanism I disabled the driver and in VESA mode it worked "fine". Since I wanted to verify that indeed driver version were the main culprit I installed Windows 8.1 and tried there with Catalyst 5.7 and 5.11beta – both failed to show a picture, although VESA worked fine before and RDPing showed that driver installation showed no errors.
      Now my theory is, that due to the relative uncommoness of my setup (UEFI + Games + Afterburner + ARMA) maybe there was some race condition induced in some NVRAM-chips which now disables the sucessful loading of the Catalyst driver. The UEFI seems ok, since VESA mode works just fine. Maybe someone knows some answers to my problem or can link me to a tool to reset all NVRAMS on the GPU to factory default, so my VM can work again as intended.


      Thanks in advance for any helping comments!