AnsweredAssumed Answered

Windows changing resolution after boot.

Question asked by angrypup on Nov 16, 2015

Hi guys! I really need your help with this one.

Few days ago I upgraded from HD7850 to R9 390x. After uninstalling the old drivers I removed my old card, put the new one in and restarted my PC. After first boot my screens changed and my main display wasn't main any more. I never really bothered about it as the drivers weren't there etc.

I installed new drivers and restarted PC. My second monitor was still acting as main and my main changed its resolution from 2560x1080 to 1920x1080. I went to screen resolution settings in Windows and swapped the screen position and resolution back to normal. It was fine until a restart.

Each time I restart my PC, all the settings are reverted and my second monitor is set as my main and resolution on my main is changed. It loads fine (with the correct settings) but about 5-10 seconds after Windows loads, it changes.

 

What I did so far:

 

  • I installed Display Fusion hoping that it would control it but no luck. I can save a profile and it will work if I load it but it's not active by default.
  • I wiped the drivers using Display Driver Uninstaller (old Driver Sweeper) from Guru3D and reinstalled the drivers. I tried both newest ones and beta, no changes.
  • I unplugged my second screen, leaving only the main one on. Restarted my PC, letting it "register" the screen. It works OK with one screen, the resolution stays correct (2560x1080). After plugging the second screen, resolution changes (after reboot).
  • I tried and removed all the "ghosted displays" using "Show Hidden" in the Device manager but no change.

 

Also, not sure if that is be design or is this a "clue" but whenever I right click on the Catalyst icon in the tray, I can see 6 displays. First and second are the actual displays and the rest of them have everything greyed out but the option "Extend to this display". If I click on that, nothing happens.
I will try to get some pictures and/or videos later on (writing from work).
Any ideas how to fix it guys?

I forgot to mention, I did, in the same time change my CPU from FX6100 to FX6350.

 

Spec:
ASUS M5A99X Evo R1, AMD FX6350, 16GB Ram, R9 390x. Windows 10 x64 Screens : Main one - ASUS MX299Q (using HDMI), Second one: ASUS VE247H (using DVI).

Outcomes