AnsweredAssumed Answered

R9 380 (Windows 10) - apps that use OpenGL are not working properly

Question asked by shavit on Nov 13, 2015
Latest reply on Nov 14, 2015 by john007

Well, it's not something that only I experience, but many with an R9 series GPU and Windows 10 do.

I suspect that OpenGL is just broken for us.

 

For example, this is with Firefox (hardware acceleration enabled): RES is broken for me - YouTube

The following CSS: "filter: hue-rotate(2deg);" will disappear when I have hardware acceleration enabled.

Firefox uses OpenGL for hardware acceleration (which is called WebGL afaik?)

 

I'll prove that OpenGL apps are literally buggy: obs issue - YouTube

That's when I use OBS' DirectX renderer (+ its "Game Capture") to record an OpenGL application, for example; "The Binding of Isaac: Rebirth" (the issue also exists with Afterbirth), or osu!.

osu! has multiple branches, one of them is outdated and uses DirectX to render the game, the issue does not exist with the osu! DirectX renderer, but it reproduces with the newer OpenGL release.

The same issue happens with DotA 2 Reborn running with OpenGL (using -gl in startup options), the issue doesn't happen when I use the native DirectX renderer.

To fix this issue when recording I simply make OBS use OpenGL as a renderer, which breaks screenshotting in all of those games and gives me very low in-game performance and overall dropped frames which can be clearly seen in the recorded video.

 

I did not suffer from any of those issues with Windows 7 and 8.1.

Also didn't suffer from those with an nvidia GTX 650 card, on both Windows 7 and 8.1.

I'm really sick of this and it makes me want to rollback to Windows 7.

 

I sent multiple reports to AMD. The issue is not solved, I got no response and we got 2 beta driver updates since then.

We need it solved. Can we get a serious reponse from AMD?

 

T H A N K S.

Outcomes