AnsweredAssumed Answered

Crucial Storage Executive will not detect my Crucial SSD. Crucial support suggest its a problem with the SATA drivers

Question asked by horalkaeu on Nov 11, 2015
Latest reply on Nov 12, 2015 by backFireX64

Id like to update the firmware of my Crucial MX100 SSD. Crucial recommends using their software, Storage Executive.

 

The problem is, it wont detect my SSD. It just shows it as:

 

Drive0 - The drive is currently busy performing an operation.
Model number is currently unavailable.

 

I thought this was the software problem, so I asked on the Crucial support forums. They replied that its probably problem with SATA drivers since other users had same problem on AMD chipset and I should try reverting back to older one or to Windows one.

 

I've had this issue since I first tried to use Crucial update, and that was on 14.12 (Omega) chipset drivers. The current version I have installed is from 29th of March 2015, version 1.2.1.402. I should mention that downloading latest available chipset driver (15.7.1) shows that the SATA driver is actual and doesn't need to be updated.

 

The SSD works perfectly in Windows, so there are no issues there, thankfully.

 

I'm running Phenom II X4 955, ASUS M5A97 Pro, Kingston 8GB DDR3, MSI R9 380 and Windows 7 x64.

 

Should I try reverting the drivers? If so, how should I do that? Last time I tried doing it, I accidentally also uninstalled my USB drivers and almost was forced to install Windows from scratch (lucky me that I had old PS/2 keyboard laying around )

Outcomes