1 Reply Latest reply on Nov 10, 2015 1:27 AM by backFireX64

    r9 290x black screens

    benzgod69

      Hello, I've recently purchased this graphics card Open Box: SAPPHIRE TRI-X OC Radeon R9 290X 100361-2SR 4GB 512-Bit GDDR5 PCI Express 3.0 CrossFireX Support Video Card - …

      When I was installing it, I realized my power supply was under powered and I went and Purchased an Antec 1000W PSU and it fixed the issue of my PC not booting up with the GFX card installed, after I put everything back together booted up windows 7 updated my drivers with the disc Sapphire gave me, I tried playing a game, (Counter-Strike:Global Offensive) everything was fine, except sometimes when loading up the game my monitor would hibernate my PC was still on but the Monitor just turned off, and I had to turn off my PC by holding the power button down. I thought it was a driver issue, so I uninstalled the old drivers and went to amd's website and downloaded the new drivers. But I still ended up with the same issue, so I just recently reinstalled windows 7, and I downloaded the new drivers, but whenever I open Steam or Google Chrome, My monitor hibernates or it freezes and occasionally I will get BSOD. I'm stumped of Ideas on what to do...I've spent countless hours looking for fixes and nothing has worked..

       

       

      PC SPECS

      CPU: AMD A10-7700K Kaveri Quad-Core 3.4 GHz Socket FM2+ 95W AD770KXBJABOX Desktop Processor AMD Radeon R7 …

      PSU: Antec HCP Platinum HCP-1000 1000W ATX12V V2.32 / EPS12V V2.92 SLI Ready CrossFire Ready 80 PLUS PLATINUM Certified Full …

      MotherBoard: ASUS A88X-PLUS FM2+ / FM2 AMD A88X (Bolton D4) 8 x SATA 6Gb/s USB 3.0 HDMI ATX AMD Motherboard …

      Ram: G.SKILL Ripjaws X Series 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800) Desktop Memory Model F3-12800CL9D-8GBXL …

       

      Any ideas on what I could try to do?

        • Re: r9 290x black screens
          backFireX64

          Try using another cable and/ or another port. You may have a damaged/ mulfunctioning port on your gpu adapter or on your monitor.

           

          Make sure that the windows power plan is set to "high" and that the screen does not use any power save mode in windows or in it's own menu options.

          Don't use any screensaver or pc hibernation mode either. (all the above is just a precaution)

           

          Or it may just be a bad card, or a card with unstable voltages and clocks, so try experimenting with msi afterburner a bit.

          Make sure to also clean install the latest drivers (15.7.1 or 15.11 beta).