0 Replies Latest reply on Nov 2, 2015 10:22 AM by gilliam857@gmail.com

    r9 290x black screen at 4k 60hz

    gilliam857@gmail.com

      I know there are MANY other posts about this but I still see no set resolution.

      I have a Sapphire Tri-x R9 290x, which seems to work fine until it is connect via display port to my Acer B286HK monitor.

      Connecting via HDMI works fine and I am able to get 4k 30hz with no issues.

       

      I know the cable is fine because previously I have used my GTX 770 without any issues at all and I am about ready to switch back if I cannot figure this out.

      The whole process has been a nightmare.

       

      After I finally got everything working and installed the issues started.

      I was able to initially get it working at first install. I tried to launch one game and it launched at the lowest resolution before crashing, and then the display went black. Monitor has input signal, but only displays black screen. At the time I had my 2nd monitor connected via HDMI and it was working fine, but since then I have not been able to get my Display port cable to work at all.

       

      I have tried reinstalling the 290x, which really doesn't make any sense, even uninstalling all the AMD drivers, and obviously I have removed all of the previous drivers too. and reinstalling them. I know this is not a hardware issue because the Display port cable works up until the drivers reinstall and then sets my resolution to 4k 60hz. Instant black screen.

      I have tried the latest driver and the beta driver. Both have exact same result.

       

      I notice posts about this that go all the way back to this time last year, and I find it unbelievable that there is no solution. This is what this card is designed for and I cannot even get it to work.

      So before I go out throwing money at a new Display port cable when the one I had was working perfectly fine with my 770 that I should probably just got back to using and call it a day. Is there anybody else that can provide some input on this?

       

      Current system specs:

      MSI P67a-gd65 (B3) motherboard

      i5-2400

      2x4gb corsair 1600mhz ddr 3

      thermal-take tr-600 PSU (i know its bad, but lets be real here and not go blaming this for this issue)

      windows 10 installed on sandisk ultra plus 128gb ssd