AnsweredAssumed Answered

Computer crashes/restarts during Starcraft 2 Heart of the Swarm campaign on Fury X

Question asked by watchingeyeball on Oct 28, 2015

After finishing Wings of Liberty, I aimed to complete the campaign for Heart of the Swarm before Legacy of the Void was released. However I quickly found that I was unable to do that on my Fury X card. Anytime a cut-scene occurs in the campaign, or I start a conversation on the Leviathan, my computer restarts itself. There is no error message involved. My screen goes black as my computer turns off, then it instantly restarts itself.

 

I am posting this so other Fury X owners that encounter the issue may be aware of what I went through. After submitting seven tickets with Blizzard. here is a list of all the work around that I tried:

 

    • I have made sure my graphics drivers are up-to-date.
    • I have uninstalled/reinstalled Startcraft, and run the repair function.
    • I have tried playing the game with all the non-Microsoft System Services disabled.
    • I have added in the "frameratecapglue=30" and "frameratecap=60" lines into my Variables.txt file.
    • I have changed "GraphicsOptionMovies=3" to "GraphicsOptionMovies=0".
    • I have tried running the game in Windowed mode with those lines.
    • I have uninstalled Norton and tried to run the game. I reinstalled it when we eliminated that as an issue.
    • I have launched System Filed checker, and it found no errors.
    • I ran scandisk on my SSD and the HDD Starcraft is on.
    • I Defragged the HDD Starcraft is on.
    • I tried running the game in 32Bit.
    • I tried using the Beta Drivers for the Fury X.
    • I changed the Affinity to disable one of the cores of my CPU for Starcraft.

 

 

Out of all those above methods, nothing was successful in preventing my computer from restarting during the cut-scene/conversation in the HOTS campaign.

 

The only solution that I found was to replace my Fury X with my old 6970. After switching out the cards, I had absolutely no issues whatsoever. As a result, I have concluded that the issue is with the drivers for the Fury X. If you do not have another GPU, the only course of action seems to be to wait for functional drivers.

 

I am posting this in order to give some insight to other Fury X owners that happen to encounter this issue, and to raise some awareness of a rather large issue with the Fury X drivers. I am pretty upset that I am still experiencing large issue with my Fury X.

 

Incase it helps, here are my specs:

  • CPU: Intel i7 5820k
  • GPU: R9 Fury X
  • Motherboard: Asus x99-A
  • RAM: Corsair Vengeance LPX 16GB (2x8) 2400MHZ
  • PS: Corsair HX 750W
  • Heatsink: Noctua NH-D14
  • OS: Windows 10 64bit
  • Runnning at 3840x2160 on a Dell P2715Q

Outcomes