1 Reply Latest reply on Apr 6, 2016 5:14 PM by jackwraith

    AMD Catalyst Install Manager and Catalyst Control Center fail constantly to install

    cabohitman

      Hi everyone.

      I've emptied my choices so this is my last resort.

       

      Before we start, this are my specs:

      Spec
      Version
      OSWindows 7 Professional (x64) Service Pack 1 (build 7601)
      MainboardASUSTeK COMPUTER INC. M5A97 LE R2.0 Rev 1.xx
      Processor3,80 gigahertz AMD FX-8320 Eight-Core
      GraphicsAMD Radeon R9 200 Series

      Any other required detail, will be provided ASAP

       

      I bought this pc by pieces and set it up myself about a year and a half ago. I didn't have any problems with my old display, as HD (760p) resolution worked pretty fine, but I've recently changed my display (an old HD AOC LCD screen) for a new one (LG 43" Full HD) and I noticed that when set on 1080p resolution, it wasn't showing properly. The graphics (colors, text and visual quality overall) and the resolution itself (it didn't show the whole screen, as the "borders" were "outside" the screen) were all wrong. So to fix it, I had to set it up from Catalyst Control Center but my surprise was that It was nowhere to be found.

       

      Long story short: I ran Windows Update until no new update was available. I've tried reinstalling the drivers, uninstalling them, cleaning the registry, reinstalling, install config tweaks, trying everything again from safe mode, forcing administrator user and it just won't install. And any combination of those.

      I downloaded the recommended catalyst drivers version and stuff (15.7.1) and when I'm installing, it shows an error:

       

      AMD Catalyst Install Manager

      Application Install: File Not Found

       

      Every single time, with any combination of the above mentioned. The last time I tried, I had uninstalled the driver, swept everything with DriverSweeper, got my registry clean with CCleaner, defragged the disc, manually erased any AMD files remaining, and it still couldn't install.

      I've downloaded the install file several times already and nothing works. I even tried with the beta drivers and nothing. It's been almost a whole week trying.

      I'm seriously considering changing my card to an Nvidia one if this can't get fixed. It's been quite astounding, dissapointing and very frustrating.

       

       

      Thanks and please try to forgive my english, since it's not my native language.