AnsweredAssumed Answered

Catalyst 15.7.1 stopped working Windows 10

Question asked by cablenexus on Oct 27, 2015
Latest reply on Oct 30, 2015 by cablenexus

Hello,

 

Since a few month I use Radeon R7 250 graphic card and Windows 10 without any problems.

 

Last week I tried to update my Catalyst software because I got message there was an update available.

 

I download the Catalyst 15.7.1 software package for Win10 and extract the package.

As soon as installation start an error message popped up that Catalyst host stopped working and the program closes itself.

I cannot even choose "standard" or "custom" installation because it closes before I can make that choice.

 

I tried again with my anti virus (AVG free) disabled but without any luck.

 

I search Windows update to see if I missed any important updates without any luck. All .Net and C++ software is up to date.

 

I restarted my system and tried again without any luck.

 

I go to Windows apps menu to uninstall Catalsyt software from the uninstall apps menu but as soon as the uninstall program starts I got the same error message that Catalsyt host stopped working.

 

I uninstalled the Catalyst software and all my drivers with the uninstall tool from the AMD website and cleaned my registry and any ATI/AMD folders left afterwards.

After I restart again I tried to install the software package again and the same error message popped up.(catalyst 08.00.0916 stopped working).

 

In the display manager I can install the graphics driver manual with the driver from the extracted package from the Catalsyt 15.7.1 software package, but as soon as I start to install/uninstall/reinstall anything related to Catalsyt Control Center the program crashes.

 

I tried both the 15.7.1 and the 15.10 beta driver without any luck. I tried both my native language (Dutch) and standard English driver.

 

I send a service request to AMD three times with a complete list of problems I encounter and the only answer thy send back to me is if I have the newest Direct X, what my power supply is and if it happens with all games or just with some games.... So AMD support is a complete joke.

 

I don't know what to do anymore to install the Catalyst control center. Any ideas? Thank you for your time.

Outcomes