AnsweredAssumed Answered

Expected Error: Unsupported device! Required CL_DEVICE_OPENCL_C_VERSION 2.0 or higher

Question asked by pepe78cuba on Oct 20, 2015

I am getting error from CalcPie example provided in AMD APP SDK 3.0

 

I tried both drivers:

 

Catalyst Software Suite286 MB15.7.17/28/2015

as well as:

 

Latest Beta Driver301 MB15.10 Beta

10/12/2015

 

I have two graphic cards which should work with OpenCL 2.0, but they both get the same error:

Expected Error: Unsupported device! Required CL_DEVICE_OPENCL_C_VERSION 2.0 or higher

 

My graphic cards:

Radeon R9 Nano & Radeon HD 7970

 

so I don't get why it does not want to run OpenCL 2.0. When I look at deviceInfo:

+   deviceVersion    0x00ba5300 "OpenCL 1.2 AMD-APP (1800.11)"    char *
+   openclCVersion    0x00b97e60 "OpenCL C 1.2 "    char *

 

so - in VS Express 2015, is there any special compiler switch I should use?

 

Thanks,

Peter

Outcomes