AnsweredAssumed Answered

Catalyst Won't Open - Windows 10

Question asked by daemonsoul on Oct 8, 2015
Latest reply on Nov 4, 2015 by daemonsoul

System Specs:

  • Intel i7 Extreme 980X
  • 24GB DDR3 RAM
  • 2 x Radeon HD5970 in Crossfire (not sure if Crossfire is enabled now, due to the problem detailed below)
  • ASUS P6X58D Premium MOBO
  • Windows 10 Pro

 

Catalyst Control Center will not open on my Windows 10 Pro machine. I tried opening Catalyst Control Center (15.7.1), and it did not open. I rebooted, still nothing. Followed the instructions at http://support.amd.com/en-us/search/faq/58 . I uninstalled the drivers, but when I got to safe mode there were no public token keys in my Windows\Assembly folder that matched "90ba9c70f846762e".

 

I reinstalled 15.7.1, Catalyst didn't open. I went back into safe mode and tried using Guru3D's DDU (Display Driver Uninstaller), followed the instructions exactly, reinstalled 15.7.1, nothing. Used DDU again, tried the beta driver (15.9.1) - Catalyst won't open. I went into the Window's features and removed/reinstalled .NET (Windows 10 comes with it).

 

I've tried every trick that has been listed:

Catalyst Control Center Won't Open

Catalyst Control Center won't open after 6/3/2015 update - Microsoft Community

Fix - Catalyst Control Center - CCC - will not open/install Solved - Windows 7 Help Forums  (same as the AMD Support)

Just to name a few.

 

I'm at my wit's end: I don't want to restore the system to the image I made when it was ready, and apart from that the only thing I haven't tried is using a system restore point. I haven't added any new hardware or drivers, no new programs - it just stopped working. The only thing I can think is maybe a Windows Update did something to .NET.

 

Can anyone think of something that isn't listed? How do I talk to AMD? I can't find a contact link for them. I really don't want to go mucking around with System Restore or System Image - it is time intensive and annoying.

 

Thanks.

Outcomes