AnsweredAssumed Answered

Catalyst and drivers causing issues

Question asked by jarodoflua on Sep 30, 2015

(Using Radeon R9 380, MSI motherboard, and Intel APU)

So a computer I ordered arrived yesterday, but there was a "thread_stuck_in_driver" error when I tried to start windows. After much troubles, I decided to re-install Windows 10. I did so, and it booted correctly.

 

I installed most of the necessary programs and drivers (None of them being AMD yet), and then downloaded the Auto-Detect Utility and executed it. It did show that I had an AMD Radeon R9 380, even though I was having doubts since the Windows Device Manager showed that I only had two display adapters, both apparently Microsoft, and one not working for an unknown reason.

 

After a while, it said the download had finished. Okay, I had no idea what to do from there, as it sort of just said "Download finished" and didn't do anything like installing it. So I tried for a manual download. I downloaded "Latest Beta Driver" version 15.9 beta because I only thought that Catalyst was just a convenience, and I wanted the driver itself (This being the only thing containing "driver" on the downloads list).

 

During the installation, my screen went black (But the signal to the monitor was still present, and note that I am still using an Intel APU), and it persisted for an hour until I finally forced a shutdown (As the PC was not responding). Now, whenever I boot up, the display works fine until Windows starts loading, and once Windows starts loading it goes black again, signal still going to the monitor, computer not responding.

 

I really don't want to have to re-install Windows again, and when/if I do, what will I do about the AMD drivers? (Which have been causing more problems than what is mentioned here, the other problems just never persistent like this)

Any advice?

Outcomes