1 Reply Latest reply on Nov 17, 2015 10:44 AM by tech

    MSI R9 390X - Low GPU usage - Low FPS - Frame drops - Stuttering

    dum9

      Hello guys!

       

      So it's been a month with this GPU and I've been kinda dissapointed. The only games that I can play properly are CS:GO and League of Legends. Other DX11 titles are a mess: my GPU usage is low so I get either low fps, frame drops or stuttering.

       

      I've tried remounting the GPU, overclocking, downclocking, setting the power limit settings up or down, replacing the PSU, reinstalled drivers (15.7.1, 15.8, 15.9 and the ones that came on the CD in the GPU's package), fresh installed Windows and so on..

       

      In idle, the GPU never went above 60C, and in games, the most I had was 75C. In Unigine Valley it reached 80C though.

       

      In Unigine Valley this is the score I had, which was pretty dissapointing: http://i.imgur.com/h0fBVZr.png

       

      Here you can see my problem: Low GPU usage/Low FPS/FPS Drops/Stuttering [MSI R9 390X] - YouTube

       

      The thing is I even play at 768p in the video above, even though I encouter the same problem at 1080p.

       

       

      PC Specs:

       

      Windows 8.1 Pro 64bit

      i7-4770

      AsRock H87 Fatality Performance

      MSI R9 390X

      8GB RAM 1600MHz

      700W 85% 80+ Bronze

      250GB SSD

      1TB HDD

       

       

      Thank you in advance guys!

        • Re: MSI R9 390X - Low GPU usage - Low FPS - Frame drops - Stuttering
          tech

          My GTX 670 gave its life in service of +3y of great gaming and I tought it was time to try something new.

          I went to the store and bought a MSI R9 390x 8GB. Thats when the trouble began.

           

          I have the same problem, massive framedrops, when I look at the GPU usage it is everywhere between 0 and 100%, never stable.

          In those moments when it realy counts, those heavy firefights/head to head races, it drops to 0% and games freeze for a sec or more.

           

          Tryed msi afterburner, locked clocks and so on, nothing worked so far.

          Lastest drivers installed, I even did a clean W10 install.

          GpuZ detects the drops, CCC detects the drops, GPU shark only shows 4GB working ram.

          Ingame its a mess

           

          I7 3770K

          ASUS P8Z77-V

          MSI R9 390x 8GB

          intel SSD 245GB x2

          Corsair 750W pro

          corsair 16GB 1600Mhz

          W10 64bit pro