0 Replies Latest reply on Sep 25, 2015 5:06 PM by zchris

    install fail system crash Mint 17.2, Radeon R7 200 (Asus A88XM-E)

    zchris

      Unable to install driver after several attempts. Generally system crash on startx after attempting install of Catalyst 3 different ways.

      Is Mint 17.2 orAsus A88XM-E unsupported?

       

       

      Before each attempt, fresh install of Mint 17.2 from DVD, followed by
      apt-get update
      apt-get upgrade
      reboot

       

       

       

      Attempt #1


          apt-get install fglrx

          Crashes the system.

       

       

      Attempt #2

       

      Downloaded these:
         fglrx-core_15.201-0ubuntu1_i386_UB_14.01.deb
         fglrx-dev_15.201-0ubuntu1_i386_UB_14.01.deb
         fglrx_15.201-0ubuntu1_i386_UB_14.01.deb
         fglrx-amdcccle_15.201-0ubuntu1_i386_UB_14.01.deb

       

         ...and followed http://www2.ati.com/relnotes/amd-catalyst-graphics-driver-installer-notes-for-linux-operating-systems.pdf
          including amdconfig --initial

       

          upon typing 'startx' system crash.

       

              no X server log.
              in syslog: Sep 25 10:56:51 kat console-kit-daemon[944]: GLib-CRITICAL: Source ID 48 was not found when attempting to remove it
      ^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@

       

       

       

      Attempt #3

       

      Tried downloading and running
          ./AMD-Catalyst-15.9-Linux-installer-15.201.1151-x86.x86_64.run --buildpkg Ubuntu/trusty

       

      Fail on several dependancies: Unable to resolve  debhelper  dh-modaliases xserver-xorg-dev (>= 2.  Please manually install and try again.

       

          apt-get install dbhelper
          apt-get install dh-modaliases
          apt-get install xserver-xorg-dev

       

          apt-get install execstack           # also required from the next run

       

          This created:
          fglrx_15.201-0ubuntu1_i386.deb
          fglrx-amdcccle_15.201-0ubuntu1_i386.deb
          fglrx-core_15.201-0ubuntu1_i386.deb
          fglrx-dev_15.201-0ubuntu1_i386.deb
          fglrx-installer_15.201-0ubuntu1_i386.changes

       

          dpkg -i *.deb
          amdconfig --initial

       

          startx..  Crash.
          in syslog:
          Sep 25 14:13:52 kat mtp-probe: checking bus 3, device 11: "/sys/devices/pci0000:00/0000:00:12.0/usb3/3-1"
      Sep 25 14:13:52 kat mtp-probe: bus: 3, device: 11 was not an MTP device
      Sep 25 14:14:11 kat rsyslogd: [origin software="rsyslogd" swVersion="7.4.4" x-pid="654" x-info="http://www.rsyslog.com"] exiting on signal 15.
      ^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@
      ^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^

       


          Tried rebooting and running "Xorg -configure"

       

          X crashes:

       

          (++) Using config file: "/root/xorg.conf.new"
          (==) Using system config directory "/usr/share/X11/xorg.conf.d"
          (EE)
          (EE) Backtrace:
          (EE) 0: Xorg (xorg_backtrace+0x4f) [0xb76de1bf]
          (EE) 1: Xorg (0xb7535000+0x1acfa4) [0xb76e1fa4]
          (EE) 2: (vdso) (__kernel_rt_sigreturn+0x0) [0xb7510d38]
          (EE)
          (EE) Segmentation fault at address 0x0

          Fatal server error:
          (EE) Caught signal 11 (Segmentation fault). Server aborting
          (EE)