6 Replies Latest reply on Sep 29, 2015 9:45 AM by chfast

    aticonfig needs X running

    chfast

      I have fglrx dirvers installed and X running. However the X does not use AMD GPU, fglrx driver is not used by X.

       

      aticonfig does not allow me to perform some of the Overdrive commands like --od-getclocks. The error is:

      ERROR - X needs to be running to perform AMD Overdrive(TM) commands.

       

      Is there any workaround for that?

        • Re: aticonfig needs X running
          bhavik

          Hi,

           

          We are running into the similar issue. The only difference is we are trying to run just an adapter query command (aticonfig --lsa) to get the installed GPU information on our Linux machines.

           

          It seems aticonfig binary requires X session else it doesn't work. It will be best to have an alternate version of this utility that can run without X session to be able to query such a basic information.

           

          Please point me to more information if there's already an alternate way to get only the installed GPU and drivers information. For example, what the nvidia-smi does for the NVIDIA GPUs - which can be used in runlevel 3 that doesn't require X session.

           

          Let me know if there's more information required on my part.

           

           

          Thanks,

          Bhavik

            • Re: aticonfig needs X running
              chfast

              I don't think there is actually a need for the alternative tool. Some of the aticonfig queries work without X running (e.g. --list-adapters, --px-igpu, etc.).

                • Re: aticonfig needs X running
                  bhavik

                  Okay, I have tried this again but this time with "sudo" and that seems to be working for "aticonfig --lsa" - for example,

                   

                  sudo aticonfig --lsa

                  No protocol specified

                  * 0. 06:00.0 AMD FirePro W7000 (FireGL V)

                   

                  * - Default adapter

                   

                  But as you'd notice it required me to use "sudo" access, which is not feasible for us in this particular case, as we need to run this command from our pipeline scripts for automation.

                   

                  Also, for more info, if I'd try to run it without "sudo" access it gives this error -

                  aticonfig --lsa

                  No protocol specified

                  aticonfig: This program must be run as root when no X server is active

                   

                  But, If we do have the X running OR in this particular case - If I have SSH to this machine with X forwarding enabled - the same command is working without "sudo" access

                  aticonfig --lsa

                  * 0. 06:00.0 AMD FirePro W7000 (FireGL V)

                   

                  * - Default adapter

                  That's exactly what we are looking for - being able to query the GPU and driver information from command-line without "sudo" access as well as without "X" session. Any help on this will be greatly appreciated! Thanks!

                    • Re: aticonfig needs X running
                      chfast

                      I've tried the ssh -X trick suggested, but it does not work for me. I'm getting the same error:

                      aticonfig --od-getclocks

                      ERROR - X needs to be running to perform AMD Overdrive(TM) commands.

                       

                      The X is actually running, but without fglrx driver loaded (intel only).

                        • Re: aticonfig needs X running
                          bhavik

                          I am on the same page with you as far as "aticonfig --od-getclock" is concerned, however, the "aticonfig --lsa" is working as a non-root (or non-sudo access) with SSH -X

                           

                          aticonfig --od-getclock

                          ERROR - X needs to be running to perform AMD Overdrive(TM) commands

                           

                          aticonfig --lsa

                          * 0. 06:00.0 AMD FirePro W7000 (FireGL V)

                           

                          * - Default adapter

                          I'd suggest if you can test the same and post your findings on this thread w.r.t. "aticonfig --lsa"