AnsweredAssumed Answered

7970m drivers

Question asked by ironcladrooster on Sep 11, 2015
Latest reply on Oct 14, 2015 by bonfire62

Hey all,

 

So I upgraded to Windows 10 on my machine and everything was going fine for about a week until one day I was gaming and I got a BSOD with error code "Thread stuck in device driver". After that I couldn't boot up a game at all without another BSOD coming up. I did some troubleshooting, but couldn't find a solution anywhere so I decided to downgrade back to Windows 7. Thankfully I haven't gotten any more BSODs, but now I can't install any drivers for my AMD card! It's been driving me crazy!

 

As you know the Sager NP9170 has both the Intel integrated graphics as well as my dedicated AMD 7970m card. I've been able to install the Intel graphics okay, but when I go to install the AMD drivers it doesn't work. The installation process begins and I can pick where I want to install the drivers and can also pick whether I want the custom or express install option. Then it starts installing and the little green bars start to fill up and BAM - the computer goes to a black screen with a blinking underscore (_)in the top left corner. And then it just sits there for as long as I leave the computer on. I've let it sit for four hours like that with nothing changing.

 

So yeah - that's annoying.

 

I've tried firing up a game like this and it works, but it only uses the intel integrated graphics because the drivers for the AMD card are incomplete or missing.

 

Here are a couple other things I've tried.

I've done complete driver uninstalls (for both intel and AMD) by using Guru 3d's Display Driver Uninstaller.

 

Then I reinstall intel's driver's first followed by AMD drivers. (error with black screen comes up when I try to install AMD drivers)

 

I've also gone back to the stock drivers from the Sager website - the 2012 versions - and I still get the same black screen. (Note I've completely wiped my drivers between each attempt by using the DDU tool)

 

I've also tried to use the latest "Leshcat Catalyst WHQL" combo driver set. I read in some places that people had luck with this. But no dice for my rig.

 

Out of desperation I have completely formatted the hard drive and reinstalled Windows - all to no avail.

 

Anyone have any experience on how to fix this? It's been broken for over a week now and it's driving me crazy. I'm happy to post any diagnostics or files if that would help diagnose it.

 

Thanks in advance

Outcomes