2 Replies Latest reply on Dec 2, 2015 1:00 AM by bigjou

    Drivers for Ubuntu 14.04 don't work

    dominik1123

      Hello,

       

      I'm having trouble installing the Radeon drivers for Ubuntu 14.04.

       

      First about my system:

       

      Model: HP Pavilion dv6

      CPU: Intel Core i7-2670QM CPU @ 2.20GHz

      Memory: 6GB

      Graphics card: Radeon HD 6400M/7400M series (could not find out the exact model)

      OS:

      • Distributor ID: Ubuntu
      • Description: Ubuntu 14.04.3 LTS
      • Release: 14.04
      • Codename: trusty

       

       

      What I tried:

       

      I originally tried to switch on my Radeon graphics card instead of the integrated unit.

      lspci -vnn | grep '\''[030[02]\]' yields the following output for the graphics devices:

       

      • 00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
      • 01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Seymour [Radeon HD 6400M/7400M Series] [1002:6760] (rev ff) (prog-if ff)

       

      I tried switching devices using /sys/kernel/debug/vgaswitcheroo/switch (following this article: HybridGraphics - Community Help Wiki ).

      cat /sys/kernel/debug/vgaswitcheroo/switch gave the following output:

       

      • 0:IGD:+:Pwr:0000:00:02.0
      • 1:DIS: :DynOff:0000:01:00.0

       

      but echo ON > /sys/kernel/debug/vgaswitcheroo/switch didn't change anything so I went to BIOS and changed Switchable Graphics Mode to Fixed (following HP Notebook PCs - OpenGL Applications Cannot Use Discrete GPU with Intel + AMD Switchable Graphics | HP® Customer Suppor… ) and because there was still no change I added radeon.runpm=0 to /etc/default/grub at GRUB_CMDLINE_LINUX_DEFAULT= (following Vgaswitcheroo doesn't work on 14.04 - discrete Radeon always on, Dell Vostro 3350 - iswwwup.com ).

      cat /sys/kernel/debug/vgaswitcheroo/switch now gave the following output (after rebooting):

       

      • 0:IGD:+:Pwr:0000:00:02.0
      • 1:DIS: :Pwr:0000:01:00.0

       

      echo DIS > /sys/kernel/debug/vgaswitcheroo/switch now caused the screen to turn black and didn't show any ouput. However I was able to check the content of /sys/kernel/debug/vgaswitcheroo/switch by copying it to a file and switching back to integrated graphics. The content was:

       

      • 0:IGD: :Off:0000:00:02.0
      • 1:DIS:+:Pwr:0000:01:00.0

       

      So apparently the Radeon card was powered and active but didn't output anything. I observed the same behaviour when having an external screen connected both via VGA and HDMI.

       

      (Side note: switching back to integrated graphics via echo IGD > /sys/kernel/debug/vgaswitcheroo/switch gave as output [  956.727633] [drm:rv770_stop_dpm] *ERROR* Could not force DPM to low. (probably due to the radeon.runpm=0 which I added before); however the /sys/kernel/debug/vgaswitcheroo/switch wasn't available anymore (I couldn't issue any further commands) and lspci -vnn | grep '\''[030[02]\]' didn't list the Radeon anymore.)

       

      So I thought the problem might be a missing driver.

       

       

      About the AMD driver:

       

       

      I checked the AMD website for an Ubuntu driver and found the following: http://support.amd.com/de-de/download/desktop?os=Linux+x86

      I followed the installtion manual (none of fglrx, fglrx-core, fglrx-amdcccle, fglrx-dev was already installed) but encountered an error when installing fglrx-core: there was a conflict with libopencl1. I followed this workaround: ati - 14.10 wine and fglrx conflict - Ask Ubuntu and modified Conflicts and Provides as described, then the installtion of this package and the others finished without error. However after rebooting the system told me that there is a problem with the graphics devices and that they cannot be used. I used the console log-in to remove the previously installed packages and now I have X-server again, but I'm still stuck at enabling my Radeon graphics.

       

       

      To summarize the question:

       

       

      What do I have to do in order to manually switch to the Radeon graphics card using Ubuntu 14.04? In case I need to install the above mentioned driver is the conflict with libopencl1 a problem and if so how I can work around this?

       

       

      Thanks a lot in advance!

      Dominik