AnsweredAssumed Answered

High Performance GPU Gets Locked at Low Engine Clock

Question asked by tribalbob on Aug 29, 2015

Hello,

 

I have a CyberpowerPC Fangbook Evo AX7-215 Gaming Laptop with AMD A10-5750M and R9 M290x running Windows 8.1 64-Bit.

 

Switchable graphics has worked fine for me for over a year now but recently when I am gaming, my high performance GPU will run for a few minutes with clock speeds going as high as 950 MHz for the core clock and 900 MHz for the memory clock. Then after a few minutes the clock speeds get locked at 450 MHz for the core clock and 900 MHz for the Memory clock with 100% load and I begin to experience lag/stutter.

 

I am using the latest (beta) version of the catalyst drivers (problem also persists in stable version), I am using the "High Performance" power profile, the games I am playing are configured to use the high performance GPU, I have tried manually setting the clocks using Sapphire Trixx and it works, locking the clocks at 950/900 for a few minutes and then after that the clocks lock at 450/900 and the gpu shows 100% load with lag/stuttering. I have even gone as far as re-installing Windows.

 

This is getting very frustrating as I went from being able to play pretty much anything in 4k downsampled resolution at max settings to lag/stutter on everything I play.

 

If anyone can help me figure this out it would be greatly appreciated.

 

Also, another strange thing, when I first got my laptop my R9 M290x showed with the proper name in my Device Manager and everywhere else but at some point I updated to a newer version of catalyst and ever since my R9 M290x has been identifying as an "AMD RADEON(TM) HD8970M". Is there some way I can fix this as well...?

 

Thanks!

Outcomes