0 Replies Latest reply on Sep 1, 2015 4:34 AM by doqtor

    CodeXL remote profiling issues

    doqtor

      I'm not able to run Application Timeline Trace. Any idea how to figure out what's wrong?

       

      This was working fine in CodeXL1.7 but stopped working after I upgraded to CodeXL1.8.

       

      GPU: Performance Counters profiling is working fine though.

       

      I'm using Xming. When I start profiling the window pops up and I can see the application runs fine but then the window disappears and I'm not able to see if/what the error was. I don't know if I can somehow force Xming to not close the window after or use something else than Xming or are there any logs on the remote server I could check?

       

      Additional information:

      this is Ubuntu 14.04 VM to Ubuntu 14.04 server remote profiling on opencl application using AMD R9 295 GPU.

      CodeXL Agent version is: 1.8.9654.0

      CodeXL_1.8-9654 GUI

      fglrx 15.20.3

       

      Update:

      Probably similar problem is when I run Application Timeline Trace locally on OpenCL cpu. But here I can see an error:

      Failed to generate profile result /<full path>/Aug-28-2015_15-51-03.atp.

      Generating summary pages...

      Parsing API trace file...

      No summary pages generated

       

      Update2:

       

      I used strace in local profiling and found this:

       

      [pid  2588] open("/home/ubuntu/.amd/AMD/CodeXL/test_ProfilerOutput/Aug-28-2015_21-27-10/Aug-28-2015_21-27-10.atp", O_WRONLY|O_CREAT|O_TRUNC, 0666) = 3

      [pid  2588] open("/home/ubuntu/.amd/AMD/CodeXL/test_ProfilerOutput/Aug-28-2015_21-27-10/Aug-28-2015_21-27-10.amdtperfmarker", O_RDONLY) = -1 ENOENT (No such file or directory)

      [pid  2588] unlink("/home/ubuntu/.amd/AMD/CodeXL/test_ProfilerOutput/Aug-28-2015_21-27-10/Aug-28-2015_21-27-10.atp") = 0

      [pid  2588] open("/home/ubuntu/.amd/AMD/CodeXL/test_ProfilerOutput/Aug-28-2015_21-27-10/Aug-28-2015_21-27-10.atp", O_RDONLY) = -1 ENOENT (No such file or directory)

       

      For some reason .amdtperfmarker file was not created then because of that .atp file is deleted. But I'm unable to find what was the cause ...