0 Replies Latest reply on Aug 27, 2015 8:22 PM by chazy

    disable monitor off autodetection in linux

    chazy

      Hi there! I have a multi-monitor configuration (3 monitors) and my problem is that when i turn off one of them the others also turn off and are autodetected; this causes the opened windows (to go crazy) to change the current position and this is not something i want (i read no one likes this... so please drop this "feature" for future releases or at least make it disabled by default).

       

      It's really annoying because if I have some opened windows (even full screen games) in the main monitor (the middle one) and I turn on some of the others, do whatever i need (even leave there an opened window) and I turn it off, some of the opened windows from the main monitor (and from the one that i just turned off) are moved while the autodetecting feature runs (sometimes to the turned off monitor)... so I have to turn it on again and move it to my main monitor, click in the desktop or minimize the windows so that when i turn the other monitor off (again) the windows stays in the main monitor... Also if i want to leave an opened window in the monitor that i'm going to turn off it should stay there no matter what...

       

      I've been looking in the catalyst control center for an option to disable this annoying feature, but there isn't. I only found it in windows os and i think it's there just for decorative purposes, because it has no effect at all (already disabled but autodetecting when i turn off one monitor...). Since I have not much experience in linux (manjaro cinnamon) I don't want to mess with files like xorg.conf, I just search in the settings (cinnamon-settings) but no luck.

       

      This starts happening after installing the proprietary drivers (just like in windows os, exactly the same thing). So I think this must be a driver related issue (or more likely a configuration).

       

      Thanks!