AnsweredAssumed Answered

Segfault in libatiadlxx.so

Question asked by michalstaniszewski on Aug 27, 2015
Latest reply on Dec 9, 2015 by chuyangguangshin

Hi,

 

I'my trying to run OpenCL code on Dell R730 with AMD S9150 on Ubuntu 14.04 LTS

I tried so far Ubuntu 14.04 with 3.13 kernel and 14.04.2/3 with 3.16 kernel.

I downloaded fglrx driver (14.502.1040) from AMD site and build it with the following command:

 

amd-driver-installer-14.502.1040-x86.x86_64.run --buildpkg Ubuntu/trusty --NoXServer

 

It was built well and generated fglrx-core_14.502-0ubuntu1_amd64.deb package.

The package also happened to install without any problems.

 

Then my problem starts.

When I run clinfo or any other software which touches OpenCL the first time runs well.

But every next run of the same binary gives me segfault and I can see such a line in kern.log:

 

Aug 27 12:07:09 cn100 kernel: [ 1188.548800] cl-demo[2084]: segfault at 108 ip 00007f2e95a2f2cf sp 00007fff535b0890 error 4 in libatiadlxx.so[7f2e959fe000+a7000]

 

When I remove fglrx kernel module and load it again the situation happens again.

First run is ok.

Every next gives segfault.

 

The driver is in binary form so I cannot investigate what happens to cause the segfault. Probably its some memory leakage in libatiadlxx.so mentioned above or some other component related to this library.

 

I also tried the driver provided with Ubuntu distribution (fglrx-core 15.200) with exactly the same result.

 

Does anyone know any workaround for this?

Maybe it's a bug that should be tracked by AMD developer team.

 

Kind regards,

Michal

Outcomes