11 Replies Latest reply on Dec 3, 2015 4:27 PM by jakejack

    Black screen bug - can't install AMD drivers

    w0mbat

      Hello, I am the proud owner of a Sapphire HD 7870 GHz Edition. Until this morning she was running fine, but now I feel hopeless.

       

      I was running Windows 10 Pro x64 with the current AMD Catalyst 15.7.1 driver, when my system crashed playing the BO3 PC beta. When restarting, I was greeted with a black screen instead of the Windows log-on screen. I quickly figured out that the GPU drivers were the problem here, so I cleaned them using DDU in safe mode and then tried a fresh install with the 15.7.1. During the installation of the driver, the screen went black again.

       

      Basically, the system runs fine with the basic Microsoft driver, but the very second I install any AMD driver (I have tried the current versions and older ones, over a year old), my screen goes black. No matter if I clean the drivers in safe mode with DDU or not, or if I used the device manager to directly update the driver, or let Windows update do its thing.

       

      I even tried a fresh Windows 10 install and then, after formatting and 2nd time, a clean Windows 8.1 installation. The issue persists over.

       

      I am running a ASRock 970 Extreme4, a AMD Phenom II X6 1055T, 8GB DDR3, a Samsung 850 EVO and the Sapphire HD 7870. I tried Windows 10 Pro x64 and Windows 8.1 Pro x64. My system is NOT overclocked. I am using a HDMI connection.

       

      I have found users with the same issue, dating over a year back, this seems to be widespread and no one knows a solution. When will there be a fix to get my GPU working again? What is the cause. Excact ETA on the fix pls, this should be the number one priority for the Catalyst team right now!

       

      Any possible solutions? Thank you