AnsweredAssumed Answered

Unable to use latest AMD driver

Question asked by orbitstorm on Aug 25, 2015
Latest reply on Oct 2, 2015 by amdmatt

OS: Windows 10

GPU: Radeon R7 240 2GB

Driver Version: 15.200.1062.1004

Current Driver Version: 15.200.1062.1002

 

Backstory: A few days ago, I noticed my UI in World of Warcraft had become a lot larger overnight and reached out to the custom UI's author to file a bug report. According to the author, no changes had been made to the UI's scaling in the latest updates but he stated he'd investigate further. I logged out and decided to switch to a different game (H1Z1), where I noticed significant frame drop. I ignored it given that H1Z1 is demanding of my GPU and chalked that up to a bad day in gaming.

 

About few hours later, I tried logging into Minecraft for a bit and my client immediately crashed, showing an OpenGL-related error. According to Minecraft's support page, Windows 10 is the likely source of my issue:

 

If you recently installed Windows 10 and are getting errors such as “Pixel format not accelerated” or “Lack of updated graphics drivers,” you should try updating your graphics drivers. See this page for instructions on how to update your graphics drivers. You can also use drivers from your OEM (e.g. HP, Lenovo, Dell) if applicable, or Windows Update, however the drivers obtained through it may not always support the proper OpenGL (technical term for what Minecraft uses to render the game) to run Minecraft.

 

 

 

Once you’ve obtained the latest driver from your GPU manufacturer, there are some notable differences from previous version of Windows.

 

 

On Windows 10, driver updates are automatically installed on your PC whenever your GPU manufacturer (AMD/Intel/NVIDIA) has a newer driver available. On previous versions of Windows, driver updates would not be automatically installed unless Microsoft decided that they would be.

 

I first attempted to reinstall the drivers (without an uninstall) in hopes of a quick fix but still encountered the Minecraft crash. I even tried using the Auto Detect tool from AMD to no avail. I then uninstalled the AMD drivers, rebooted, and upon loading the desktop, found that Windows 10 automatically reinstalled the exact same driver that I was seemingly have trouble with. Uninstalling the driver without rebooting left me unable to update the driver because the AMD Auto Detect tool couldn't determine my OS. All in all, it was a fiasco.

 

I then decided to roll back my driver to the last update, v15.200.1062.1002 and the issue(s) I was having are resolved. I promptly disabled Windows' permission to install drivers under Device Installation Settings. A few hours ago, I noticed that my driver was .1004 again so I haven't a clue how it is being updated and evidently I need to update it or my computer will remain an inconvenience to me.

 

Is AMD driver v15.200.1062.1004 not compatible with my R7 240? Is this a bad driver installation by Windows 10?

 

I'm just looking for some answer to why I seem to be unable to use the latest AMD driver, which I've had no issue with before. To be honest, I'm regretting having ever upgraded to Windows 10 because it seems to be one thing after another. For all of Windows 8.1's faults, at least it was functional and didn't hold my system hostage.

 

Thanks.

Outcomes