2 Replies Latest reply on Aug 24, 2015 1:35 AM by mattclaw

    THREAD_STUCK_IN_DEVICE_DRIVER R9 380

    mattclaw

      I just recently bought a Sapphire Nitro R9 380 4GB version and have YET to manage to install it. I have fairly newly built system and I upgraded from Intel HD chip for graphics. Now, I have set the GPU in and tried to install latest drivers on Windows 8.1 (15.7.1) and older ones and I keep getting Blue Screen with error THREAD_STUCK_IN_DEVICE_DRIVER every single time I try to install the driver. So I am running it as a standart display driver, no drivers installed.

       

      Before that I had Windows 10 machine and was getting exactly the same issue as now.

      My Specs:

      ASUS z97-AR MB with latest bios 2501

      Intel i5-4690K

      HyperX 16GB kit, 1600MHz

       

      I have tried to uninstall drivers with the tool from guru3d.com that sets system to Safe Mode, uninstalls it and restarts the PC, and then install fresh, but still nothing. I have tried reinstalling PC, updating from all bunch of places in my PC (device managers, windows update, manual update) and everything so far has led me to the same old BSOD...

      Help??