AnsweredAssumed Answered

Thread Stuck in Device Driver (Windows 10 + AMD A10-7800 Radeon R7)

Question asked by idc on Aug 19, 2015

I've had a problem with my AMD A10-7800 Radeon R7 ever since I made an update to Windows 10. Everytime I want tot play a DVD, open a game (nothing fancy: Age of Empires 3, Civilization IV) or startup Chrome and Firefox at the same time the screen freezes. Then I get a blue screen which says that 'THREAD_STUCK_IN_DRIVER', and then the computer restarts. When I turn of my AMD graphics driver I can play DVD's, open chrome and firefox and play Age of Empires 3 on very low resolutions. Ergo... it's my AMD graphics card or driver that's causing the blue screen.

 

My System:

OS: Windows 10 Home 10.0.10240 Build 10240

Processor: AMD A10-7800 Radeon R7, 12 Compute Cores 4C+8G, 3500 MHz, (Radeon R7 is fully supported according to FAQ: Windows® 10 Driver and AMD Graphics Product Compatibility)

RAM: 4,00 GB

Sytem: x64-processor

 

I bought my desktop in June 2014

 

What I've tried:

- Uninstall CCC and letting Windows 10 automatically install the drivers (failed) (Described here: Windows 10 Support for AMD APU systems))

- Installing the newest drivers from AMD, and from my computer manufacturers support website (www medion be) (failed)

- Reverting to older drivers (I tried 15.200.1046.2, 15.200.1046.0 and 14.201.1008.1002) (failed)

 

What can I do next?

 

Kind regards.

Outcomes