1 Reply Latest reply on Aug 16, 2015 2:44 AM by tyrel

    AM1 APU (Athlon 5350) USB Ports not running at USB 3.0 mode

    tyrel

      Hi!

       

      This problem is driving me nuts, I've been trying to fix it for the past 3 days to no avail, leading to me being extremely pissed at AMD.

       

      I've recently brought an Asus AM1i-A mobo with an Athlon 5350. Everything runs fine, except all the USB ports, including the blue ones, are running in USB 2.0 (High speed) mode. I have an USB 3.0 HDD (Seagate Expansion Desk 2TB) that ran perfectly fine in USB 3.0 mode with the previous System, which was an Asrock D1800B-ITX with Intel J1800 CPU. This latter system simly had an Intel USB 3.0 extensible host controller driver and that was it, blue ports were running in SuperSpeed mode leading to the external HDD having around 120 MB/sec speeds.

       

      With this AMD rig the USB HDD does about 35-40 MB/sec which as far as I can tell is the USB 2.0 limitation, and also response times on it are generally slower. To my understanding this AMD system should have a very very similar driver, called AMD USB 3.0 extensible host controller driver, but absolutely nothing is willing to install it.

       

      Info about the drivers / ports:

      http://i.imgur.com/00dWcbK.png

      http://i.imgur.com/CZ9xA73.png

      http://i.imgur.com/MfyYoHg.png

       

      What I've tried this far:

      1. Uninstall ALL USB devices in Windows to let it redetect and reinstall them.
      2. "Scan for hardware changes"
      3. "Update device driver software..." using Windows Update
      4. Install AMD Chipset drivers from http://support.amd.com/en-us/download/chipset?os=Windows+10+-+64
        1. note that whatever I do this installer does not mention any kind of USB driver during the installation process
      5. Change USB related BIOS settings. There are only 2 of these:
        1. Legacy USB 3.0 Support - Enabled or Disabled, does not change a damn thing
        2. Enable USB EHCI Hand-off - Enabled or Disabled, does not change a damn thing
      6. Completely reinstall Windows (losing all my settings and therefore losing hell of a lot of time)
        1. Previous was 8.1, new one is 10, both have the exact same issue and driver setup
      7. Tried both the blue USB 3.0 ports, it's all the same
      8. Moved the Seagate HDD to my Z77 based desktop PC where it again runs in USB 3.0 mode without any tricks, so it's not faulty
      9. Tried the chipset driver from Asus, but appearantly it's the same as the one that AMD offers. No wonder though, it's a SoC, Asus has little to do with the drivers.
      10. BIOS is updated to the latest, which is 0701 as of now.

       

      So, seriously what the heck is wrong with AMD USB 3.0 drivers and this darned AM1 APU platform? It's driving me nuts.

        • Re: AM1 APU (Athlon 5350) USB Ports not running at USB 3.0 mode
          tyrel

          After much trial and error, after wasting days on this I've finally figured out what causes the USB 3.0 xHCI controller to "die". It keeps working of course, but - possibly due to a bug - falls back to USB 2.0 mode if the APU Frequency (Bclk) is changed to anything other than 100MHz.

           

          Whether you overclock or underclock, even by as little as 1 MHz (to 101 or 99), the USB 3.0 xHCI controller instantly bugs out. This behaviour is extremely disappointing considering that AMD CPUs only true advantage over the opposition is overclockability. Athlon 5350 "asks for it", however upon the first thought of it you instantly lose USB 3.0... not to mention that due to another bug inherited from the FM1 platform the AHCI controller also dies at Bclk clock speeds above 105 MHz. This latter can be fixed by reverting the SATA controller to IDE mode, but for the loss of USB 3.0 I haven't found any workaround this far.

           

          Again, disappointing is all I can say. This has to be fixed through a microcode / BIOS update, I don't really know, nor care how... This is the first time I picked AMD over Intel, and if this stays like that, it surely is also the last.