2 Replies Latest reply on Oct 30, 2017 1:36 PM by kip1790

    Problem with two 4k monitors and FirePro W2100

    thonimahoni

      Hello,

       

      I am currently experiencing serious problems with setting up two 4k monitors with the AMD FirePro W2100.

       

      First of all my hardware setting:

       

      • Mainboard: Asrock Z77 Pro 3
        • PCIe 3.0 x16
      • Intel i7 3770K 3rd Gen.
      • Two Dell UP2414Q monitors
        • I am using the mini-DisplayPorts v1.2 which I enabled in the OSD settings
        • the monitor is capable of runnig 3840 x 2160 pixels at 60 Hz
      • AMD FirePro W2100
        • 2 x DisplayPorts v 1.2(a)
      • Cabels
        • 2 x DisplayPort to mini-DisplayPort certificated Dell cabels which where delivered with the monitors

      My Software settings:

      • Dell monitor drivers installd using "Dell Monitor Driver Installer" (hopefully newest version)
      • AMD Drivers Installed using "AMD FirePro Control Center"
        • driver paket version 14.502.1019-150317a-183940C-Retail_End_User (newest version from the webside)
        • 2D-driver version 8.01.01.1443
      • OS: Windwos 8.1 Pro 64 bit

      Description of the problem:I can only get one of the monitors to run at 3840 x 2160 at 60Hz. The other monitor goes into standby right after I turned it on. No reboot or re-install (deleting drivers, re-installing, rebooting and other combinations) of the drivers led to sucess.I managed to get an both monitors 1920 x 2160 resolutions at the same time, but no 4k. Error:Both the native Windows display settings and the AMD control center indicate another Dell monitor but everytime I try to extend to the second monitor I get an error.Windows is telling me that "This settings couldn't be saved. Try another combination." The AMD center says "Based on the current display configuration this process is not supported." Questions:

      1. First of all, is the FirePro W2100 with my hardware settings theoretically capable of displaying on two monitors 3840 x 2160 pixels at 60 Hz? (I thoguth it could based on my research, but maybe I am wrong)
      2. Since I could get each monitor individually working correctlly I am doing something systematically wrong, I am aware of that. What is the correct setting to get both monitors to display the full resolution at the maximum framerate?

       

      I appended some photos of the error messages. Since they are in German I translated them in the "Error" section of my discussion.

       

       

      Hopefully I can get help. I am going crazy because oth this. I asuemd it would be just putting the graphics card into the mainboard and connecting the displays and installing the drivers.