AnsweredAssumed Answered

15.200.1062.1003 no overclocking under Windows 10? Also very unstable driver

Question asked by erasus on Aug 13, 2015

I just noticed that overcloking settings under both catalyst control center and msi afterburner do not seem to take effect. performance is still the same as is without overclocks (tested with various benchmarks).

Both programs report back that the overclock was successful and display the new frequencies, but when benchmarking, logs and benchmark scores indicate that there is no overclocking.

just yesterday everything was fine in this regard (15.200.1062.1002).

with 15.200.1062.1003 installed however, no overclocks are going to be had and also the gaming performance in general seems to be significantly worse. seems more jittery. dont know if it is higher frametimes because of no overclock or a bad driver.

 

I heard from someone that used windows 8.1 before, that this was a known amd driver- problem on windows 8 and 8.1, is that true? I am a former Windows 7 user, so this problem is completely foreign to me.

 

I also have to report back that the AMD drivers for windows 10 in genreal seem to be very error-prone and easily get corrupted. When i tried to overclock my gpu the entire system crashed, not just the gpu driver, and managed to take the entire OS with it. i am now on my 4th windows 10 reinstall and counting. i have never experienced such a flimsy OS before, and at least the last 2 of the reinstalls were due to file corrupten because the amd catalyst control center and/or affiliate programs/drivers crashed horribly.

 

Any tips or hints how to fix that problem? i just want to get my old overclock to work again

 

My system:

AsRock 970 Extreme3 R2.0 w. newest BIOS

Gigabyte 7870ghz Edition, newest bios (2012)

Phenom II X6 1055T at 3.5ghz

8GB Kingston Hyperx Fury at 1666mhz

Samsung 840 Evo 500gb

EVGA Supernova 750 G2 PSU

Outcomes