AnsweredAssumed Answered

Sapphire R9 390 Black Screen on startup

Question asked by rjmadcat on Aug 13, 2015
Latest reply on Aug 13, 2015 by practikill

Hi,

 

I just received my Sapphire R9 390 Nitro today.

I am upgrading from a HD 6850 that has lasted me a very long time and still going strong!

------------------------------------------

I have a I7 2600 processor

Intel P67 Mobo

8Gb 1333 mem 4x2Gb

Gigabyte 620w Power supply

-------------------------------------------

 

When I boot up my computer I get my Intel Screen showing me the basic Boot options Menus F2 BIOS F7 Flash bios update F10 Boot

Just after that I get a black screen with a 0_ on the bottum right cornor of the screen.

I have a triple 24inch display setup and for getting this fixed using only 1 display but tested it on all 3.

I have used an DVI cable Display Port and HDMI all with the same result.

I have uninstalled my Old Catalyst drivers and rebooted with the new card without success

I have booted with my old card without the drivers no problems.

I cannot enter BIOS or boot options or anything with the new card attached.

I tried to enable UEFI in my bios to disable secure boot, but that did not seem to work and froze the pc after the initial reboot.

 

Please I would appreciate any help.

RJ

Outcomes