AnsweredAssumed Answered

Unable to install AMD Drivers, setup closes on its own

Question asked by dysprosium on Aug 12, 2015

I run into a strange problem. Firstly:

Radeon HD 5830

Windows 7 Ultimate x64

 

 

Today I decided to update my AMD Catalyst and drivers from 14.12 to 15.7.1.

 

 

I did the usual thing, uninstalling all AMD stuff via the catalyst install manager at the Control Panel, then restarted my computer. I ran the new 15.7.1 catalyst installer exe. It launched into the language selection screen as normal. However, after I click "Next" I briefly see the "Express" or "Custom" install option window before the setup closes abruptly. There is no error message or anything else to indicate what happened. I've tried running it several times to the same effect.

 

 

I still had the old 14.12 catalyst setup, so I tried running that. However, it does the exact same thing of closing itself after the language selection screen. I even tried running AMD's autodetectutility.exe but that program immediately closes after launching with a brief window message about how my resolution is lower than the recommended for installing AMD graphics, despite my current resolution being 1920x1080.

I tried restarting my computer again, but I still have the same problem.

 

 

There doesn't seem to be anything else wrong with my computer. I can run browsers and other programs just fine so far. So it seems this problem is only with AMD .exes for some reason.

 

 

I am at a loss for what to do now. I have had this AMD card for some years now and have updated AMD catalyst many times before without problems until now.

Outcomes