4 Replies Latest reply on Sep 15, 2015 3:45 PM by jdorje

    GPU up-scaling can't be stopped in windows 10

    jdorje

      I have a monitor that will run at 3840x2160@30, or 1920x1080@120.  In windows 8.1 it was a relatively easy matter to use 1080 resolution with GPU up-scaling off.  The 1080 feed would be sent to the monitor.  But on upgrading to 10 this is completely impossible as far as I can tell.  For starters, if I simply go into the appropriate tab in CCC and disable "gpu up-scaling", then go to the resolution tab and change it to hdtv 1080p@60, the signal that is sent to the TV will be 3840x2160@30, seemingly upscaled from 1080 to 2160 and now with only 30 hz.  Extremely annoying.

       

      Adding a custom resolution for 1920x1080@120, via CRU, which worked fine in windows 8.1, now completely breaks the display and requires a reset.

       

      When I enter a game and set it to 1080, this works - sort of.  Sometimes it uses what the monitor calls "1080p", aka 1920x1080@60, which looks okay - but of course no way to get it to 120 hz like that.  Other games will use "1080i", which looks much worse and I assume is interlaced and possibly being scaled from some other resolution.

       

      I've tried uninstalling the display driver and reinstalling (both through windows update and via direct download), on several occasions.  I have not yet tried a fresh windows install, but it may come to that.

       

      Any advice would be appreciated.

       

      Playing with my Seiki se39uy04. Got it to do 1440p at 60hz. Playing with other custom stuff.

        • Re: GPU up-scaling can't be stopped in windows 10
          jdorje

          I can work around it by setting 1080 as the primary resolution (hackish via CRU).  The primary resolution won't be scaled, so when I change to 2160 then it works.  However this is sub-optimal.

           

          The problem remains that GPU scaling can't be disabled.

          • Re: GPU up-scaling can't be stopped in windows 10
            tmac

            I have what seems to be the same problem.

             

            I have an AMD Radeon R9 200 Series graphics card and Catalyst Control Center version 2015.0803.1559.26924, with HDMI connection to a Seiki SE39UY04 LED TV/monitor.

             

            With Windows 8.1 Pro (64 bit) I could use CCC Desktop Properties to switch between 3840 x 2160 30p Hz and
            HDTV 1080p 60p Hz, both showing full screen, and the monitor indicating the correct change in resolution. Presets also worked.

             

            Now with Windows 10 Pro (64 bit) (free upgrade), CCC can switch to 3840 x 2160 30p Hz, but applying
            HDTV 1080p 60p Hz reduces the desktop size to one fourth, in the middle of the screen, and the monitor does not notify a change of resolution  (still 3840x2160@30Hz).

            In Windows, going to Settings -> System -> Display -> Advanced display settings -> 1920 x 1080 -> Apply   does the same thing.

             

            It is possible to set the monitor to 1080p@60Hz with the following:
            Settings -> System -> Display -> Advanced display settings -> Display adapter properties -> List All Modes -> 1920 by 1080, True Color (32 bit), 60 Hertz -> OK -> Apply
            But about half an icon width of the desktop edges is past the edge of the screen. Either Windows Advanced Display Settings or CCC can return to 3840x2160@30Hz.

             

            So it looks like the display driver can do 1080p @ 60 Hz almost correctly, but only by digging down to "List All Modes." Both Windows 10 "Advanced display settings" and Catalyst Control Center will change the desktop to the correct size in pixels, but do not tell the monitor to make the corresponding change in resolution.

            • Re: GPU up-scaling can't be stopped in windows 10
              jdorje

              Tried a fresh windows 10 install today.  Problem still persists.