6 Replies Latest reply on Aug 20, 2015 7:29 PM by frankylezard

    No HDMI sound - windows 10

    justken

      I don't have any HDMI sound. My monitor properties say it has not been migrated?

      Do I assume this is a windows 10 driver issue and need to download new drivers?

        • Re: No HDMI sound - windows 10
          metagravedom

          Do you have everything set correctly in the play back devices section? for some reason when i did the upgrade it set my motherboard sound as default audio device so i had a heck of a time trying to configure the audio in windows 10 to get HDMI sound.

            • Re: No HDMI sound - windows 10
              ray_m


              Can you try doing a driver rollback (for the AMD HDMI Audio Driver in the Device Manager) and see if that resolves the issue ?

               

              Please update this thread with your findings,


              Thanks !

              2 of 2 people found this helpful
                • Re: No HDMI sound - windows 10
                  metagravedom

                  i currently don't have anything to rollback to I'm on a fresh install of windows 10. the upgrade did something to my master boot record so now I'm stuck with a fresh install of everything. is there a way i can manually roll back the drivers? also my audio dies out every couple of hours... it works but only for a bit. also im using an r9 380 so im not sure what drivers would be compatible.

                  • Re: No HDMI sound - windows 10
                    justken

                    Don't know where I found it, but somewhere I picked up that the driver was 32 Bit. Went to AMD site and downloaded 64 bit drivers for Windows 10, re booted and I think the problem is sorted. Done three re boots and it worked ok each time.

                    1 of 1 people found this helpful
                • Re: No HDMI sound - windows 10
                  richanstead

                  I'm having this problem too, after updating to latest version of the drivers.  I am on Windows 7 though.

                   

                  I have my computer hooked up to an AV Receiver, which is connected to a TV.  The image is correctly displaying on the TV, but no sound is being played.  When attempting to adjust the settings in the Playback Devices screen, I receive a "Format not supported by this device," error, no matter what my settings.  On the AV receiver, it is saying that no audio signal is being received.  Other devices connected to the AV receiver work without any hitches.

                   

                  This worked flawlessly until rebooting after installing the drivers, so I am certain the issue is linked to them.  I've attempted to roll back, but the option is greyed out in the device manager.  Also double checked that I have the 64 bit version of the drivers installed and not 32 bit, as was justken's problem. Audio works fine through my headphones, which are connected to the onboard sound card of my motherboard.

                    • Re: No HDMI sound - windows 10
                      frankylezard

                      i found on other system like mind that i'm not the only one that have problem with audio on windows 10 hdmi . After a couple of minutes (inactivity) the sound stop working and i can't have sound from every output i got . Only a reboot of my pc resolve the trouble temporary . I think it's windows and not the drivers from Amd but i just want to tell you that i got a R7 200 serie 4 gigs memory . Only on this configuration it happen ,i still got a installation of windows 8.1 on other hdd and it's never happen .

                      Hope a fix for this real problem for a good working pc .