pemartins

AMD Radeon HD 7340 graphics hw acceleration problems

Discussion created by pemartins on Aug 3, 2015
Latest reply on Aug 21, 2015 by pemartins

My laptop is an Asus X55U with a AMD Radeon HD 7340 graphic card, OS Windows 10 and I'm having trouble with video hardware acceleration.

When I run flash content I always get a green screen, some other stream platforms beside flash just give me a black screen only with sound and no image. To solve this I always have to turn off hw acceleration but this is no solution because the display is way worst and more cpu is used.

Also if I use hw acceleration in media players for streaming, lets say in xbmc, the player crashes.

 

I already had this problem while using Windows 8.1, thought that updating to Windows 10 would solve it but I had no luck. I'm not sure when the problem started.

 

The driver version I have installed is 15.200.1045.1. When I run Raptr I always get the message that there is a Catalyst Driver update (15.7.1) but when I run it the video driver installation always fails. So I don't know if I have the latest driver or not.

 

The problem is really in the video drivers. I tried deleting the video driver in the device manager (and went through hell to be able to install it back, I had to create a new user profile and do some things more and install it to be able to get it back) and, while only a generic Windows driver was being used, I tested and there were no green screens in flash nor black screens on other video stream platforms, all was fine concerning to that issue.

 

How can this be solved?

 

Thank you very much in advance.

Outcomes