1 Reply Latest reply on Aug 22, 2015 6:03 PM by del13r

    Catalyst 15 is trying to make my 1280x1024, 5:4 monitors obselete by forcing an unsupported resolution of 1920x1080

    del13r

      Hi everyone,

       

      I've tried to limit this post to just observations with a little bit of my opinion at the end after spending so much time on this issue.

       

      I have the following video card Gigabyte GV-R928WF3OC-3GD which has an AMD Radeon R9 280 chip with 3 GB of GDDR5 memory. It has 1 x DVI-I interface and 2 x mini DisplayPort Interfaces. Link: http://www.gigabyte.com.au/products/product-page.aspx?pid=4991#sp

      I have 3 monitors mounted on a stand and they are all the same make and model which is Samsung B1940MR. Link (section 6-7): http://downloadcenter.samsung.com/content/UM/201008/20100804083028218/BN59-00990D-02Eng.pdf

      The maximum supported resolution is 1280x1024 and the aspect ratio is 5:4

      2 of these 3 monitors are each connected via a Mini DisplayPort to DVI converter and the 3rd monitor uses a normal DVI cable.

      I have tested this issue with a fresh copy of Windows 8.1 Pro 64 bit and then more recently on with a fresh copy Windows 10 Pro 64 bit using the same steps and getting the same result for 2 different Operating system versions.

      Format hard drive.

      Install 64 bit windows and finish the installation.

      Start off with “Microsoft Basic Display Adapter”

      Go into advanced system settings and set “never install driver software from Windows Update” (if I don’t do this, then the WHQL Catalyst driver installs and I will have the same problem as described below).

      I install AMD Catalyst Omega 14.12 package (sometimes I even skip this step and just install catalyst 15.7.1 for the sake of a clean example and still get the same result below).

      Everything displays perfectly and my monitors display their native 5:4 aspect resolution of 1280x1024. Additionally, I am even able to enable eyefinity and play games at my bezel corrected resolution of 4088x1024. This is perfect for my racing simulator needs.

      I get a notification that there is a new driver update and it may increase performance and just be more beneficial all round to have the latest drivers.

      I uninstall the Omega 14.12 package

      I Install AMD Catalyst 15.7.1 package

      At this exact point either of the following 2 things will happen:

      The monitors go to sleep immediately whilst installing the Catalyst 15.7.1 package. Even after a reboot, the monitors wake back up until the windows loading screen completes, which is just before the GUI loads and then they go to sleep again and don’t wake back up until a reboot. I can RDP to the machine at this time so I know it hasn’t frozen.

      Or the other thing that may happen is this …

      The monitors display the following message “Not Optimum Mode” “Recommended Mode 1280x1024 60Hz”. I then use the buttons on the monitor to see what the current resolution is and it shows up as “67.4kHz 60Hz NP 1920x1080”.

      There are now black bars exactly 320 horizontal pixels wide on each side of my desktop. When I move my mouse between each monitor, the mouse does not traverse the black bars. It is as if my desktop background has been squeezed in there and looks much taller than it was previously due having to accommodate the extra 320 pixels of horizontal black space occupying either side of my desktop.

      When I open the AMD Catalyst Control Center and go to Desktop Management and then Desktop Properties, I am met with Current Mode Settings being 1280 x 1024@60p Hz.

      Another interesting observation is that there are now a few more modes in the list that weren’t there in catalyst 14.12 previous to Catalyst 15 being installed and those extra modes are not supported by my monitors anyway.

      Opinion:

      This is a bit of a backwards step from the Catalyst 14.12 Omega package given 1280x1024 is the mode that my monitors natively support, but it is obvious the driver is ignoring the 1280x1024 setting and forcing the 1920x1080 output resolution that my monitor cannot support regardless of what setting I have chosen.

      It’s as if 5:4 aspect monitors have not been previously tested with this driver package or a decision was made to quietly not support 5:4 aspect monitors with any Catalyst 15 package as I had this same issue even with the beta drivers about a month ago. I didn’t worry too much at the time as I just dismissed it as a beta bug that would be squashed in the official release. Unfortunately, this bug has not been squashed and now if I wish to use any AMD Catalyst version 15 package with my R9 280 card, I will have to replace my 5:4 aspect monitors with monitors that can handle 1920x1080 resolution. I do not wish to do this as the cost of replacing 3 monitors is quite expensive for me. Please look into why 5:4 aspect monitors seem to have this issue with AMD Catalyst 15 as the problem is not there in catalyst 14.12 even if I uninstall catalyst 15.7.1 and reinstall catalyst 14.12 that is my only method of getting my computer working normally again.

      It’s just a little frustrating. I am happy to offer as much information as it takes to fix this. Please help if you can.