24 Replies Latest reply on Aug 22, 2015 11:04 AM by mvpcabinets

    The Trust is gone

    kimkaos

      I´ve been using AMD´s  Catalyst software for years - never had any problems and every time you send out a new driver I installed it and it worked perfect

       

      The you send out 15.7 and suddenly some of my games couldn´t play - well I guess everybody can make a mistake and you was very fast to release 15.7.1 - but then the trouble really starts

       

      The whole saturday I have crashes and some BSOD´s (Haven´t seen those for years) - more games got in to trouble and even normal task like reading a mail could make my PC crash.

       

      This morning my PC wouldn´t start before after 4 attemps

       

      Now all the 15,xxxx is gone and I´m back to Omega

       

      Dear friends you better work really quick and send out a version 16 So we again can start trusting your drivers - as for now I´m continue to use Omega and Win7/64Bit and stay away from newer version

       

       

      ROG MAXIMUS VI EXTREME - 2 x ROG MATRIX-HD7970-P-3GD5 CrossfireX - i7 4770K - G.Skill TridentX F3-2133C9D-16GTX - Corsair Obsidian 650D - ENERMAX Platimax EMP1350WT 1350W - Corsair Hydro H100i - Corsair Vengeance K70 – ASUS PB278Q - Win7/64bit

        • Re: The Trust is gone
          flano

          The trust is gone but the stupid is here. I can highly recommend the simple Upgrade to Windows 10 its much better! there are so many BETTER driver releases you could of chosen between 14.12 (OMEGA?) and 15.7.1 ....

          • Re: The Trust is gone
            backFireX64

            Try clean installing, if you have not tried that yet.

            DDU in safe mode and ccleaner after that can help in some cases, but use the AMD uninstaller manager first to remove all AMD-related software.

            Catalyst 15.7 and 15.7.1 are quite solid from my experience so far on all three OS (w7, w8.1 and w10 64bit), so... i don't know why they are giving you such trouble.

             

            Nice rig by the way.

              • Re: The Trust is gone
                kimkaos

                Done that the first time I got problems.

                  • Re: The Trust is gone
                    backFireX64

                    Oh, i see... bummer.

                    Well, if you do not really need some updated or new crossfirex profiles and optimizations for some games, like F1 2015, then i guess rolling back to the last good known driver is your best bet for now, and though Omega driver was ironically a nightmare for a lot of users, if it works for you then stick with it.

                    I understand the frustration though.

                    You can always try installing a copy of windows on a separate partition/ hdd, boot from there, install chipset/ usb controller drivers, install all important and optional windows updates, and then try installing the latest 15.7.1 whql driver on a clean environment. Just out of curiosity. If it performs normally, then something else is wrong, but you'll know that it is time to do some extra hardware/ software troubleshooting by then.

                      • Re: The Trust is gone
                        kimkaos

                        There are lots of games who could benefit for some new updates - Far Cry 4 and Watchdogs still have some issues and others as well - thats why I normal gladly accept any updates from AMD - as untill now I never had any problems - maybe the new driver didn´t help all of the problems but they didn´t F-up my system.

                         

                        But the 15.x well that was not fun at all.

                         

                        About do a new partion and all that - that I will save for some more importen stuff that BF3 and 4 - For now I just play them on Omega and then hope that AMD soon will fix the problem so I can get a complete new driver that works

                  • Re: The Trust is gone
                    snaf2k

                    i think its the problem for all 7970 cards, I got 7970m and on windows 10 it keeps crashing all the time

                      • Re: The Trust is gone
                        kimkaos

                        That could be the reason

                        • Re: The Trust is gone
                          tekkiaussie

                          Sorry to inform you, but the Radeon HD 7970 Discrete card and the HD 7970M are not the same chip. The Discrete HD 7970 is a Tahiti chip and the Mobility version is a Pitcairn, that would mean that (if anything) the Mobility version is based off the HD 7850.

                           

                          As such, you cannot really say that "this is a problem with all the HD 7970 cards".

                           

                          Discrete and Mobility cards with the same "number format" are almost never based off the same chipset micro-architecture. Mobility versions, of anything, are never going to be as high end as the desktop models.

                        • Re: The Trust is gone
                          crispal77

                          Hey , I installed win10 and the corresponding driver for w10 ( catalyst- 15.7) and the games do not work me . I have to go back to win7, it should not be

                          I have a msi r9 390

                          • Re: The Trust is gone
                            crispal77

                            Sorry, era con sorry , it was with 15.7.1

                            • Re: The Trust is gone
                              crispal77

                              still not working with omega 14.12

                                • Re: The Trust is gone
                                  snaf2k

                                  What driver version does it say in device manager? is it 14.xx? Because windows 10 automatically installs 15.xx drivers and don't let you downgrade. You have to uninstall driver, refresh device manager for hardware changes, then when it shows 'microsoft default display' upgrade it to 14.xx from the folder in C:/AMD/

                                    • Re: The Trust is gone
                                      mvpcabinets

                                      Hey, I've been attempting this for a while now...

                                       

                                      I uninstalled all existing AMD CCC software from the computer.

                                      Then used DDU to remove all existing display drivers from the system.

                                      Double checked that microsoft default display driver was the only one running.

                                      Ran windows update show hide updates utility to prevent new catalyst driver from installing on its own.  (Microsoft show hide utility link)

                                      Then ran catalyst installation wizard for 14.12 (windows 7).  Chose "custom" installation.  It is not showing that it will install the display driver.  I went ahead and installed CCC from this point.

                                      Since it didn't install the display adapter, I went into device manager and chose update driver.  Browsed to C:/AMD and selected the folder the 14.12 (Win7) installer had extracted to.

                                      It attempted to install the 14.12 driver, but then hung up for a few minutes and failed.  It displayed this:

                                       

                                      update failure.jpg

                                       

                                      Any idea what I need to do?  I also attempted to install the windows 8.1 version of 14.12 without success.