0 Replies Latest reply on Jul 31, 2015 3:45 AM by gamefreak1771

    Installing New AMD Driver's lowers my resolution and installs unwanted applications

    gamefreak1771

      Hi,

       

      For the last several days, because I had been noticing performance issues slowly building up with the games I play, I decided I should update the Drivers for my AMD Radeon 6490M on my Windows 7 64-bit system. Each time I tried to install the drivers, I would check to have only the driver and Catalyst Control Center installing. While installing the drivers my screen would go black for a moment and then my resolution would be drastically lowered when it recovered, after which it was impossible to change the resolution in the normal way or to be made higher (that is to the point it used to be at). The problem did not fix itself after rebooting (meaning that the resolution was still lowered and unchangeable) and, additionally, software I had not intended to install, namely the Gaming Evolved App, was installed after I said I didn't want to install it. I would try to access CCC and would be met with an error saying there were no settings to be changed. Each time I have tried this I have just rolled back my changes using system restore, but now for some reason this time, I have no system restore point anymore,  and there is no option to roll back drivers in the device manager. I need to fix this some other way and I am at the end of my knowledge.

       

      It may also be useful to note that my laptop has switchable graphics between then AMD chip and an Intel HD Graphics Family chip. Also perhaps of note is that each of the display adapters in the device manager have Code 52 as their device statuses. I am so lost, please help.