11 Replies Latest reply on Aug 2, 2016 11:00 AM by adiaero

    Firepro Windows 10 drivers???

    enjoiskaterguy

      Windows 10 is extremely slow for me and numerous others...One issue I have found that would otherwise help isolate the various bugs in Win10 is that there are no proper Windows 10 display drivers for the Firepro graphics cards.  From a purely customer support stand point it baffles me that those in the CC/CAD/Medical/Entertainment markets are getting the short end of the stick when they pay huge premiums for their drivers and software support.

       

      When are we getting our display driver updates?

        • Re: Firepro Windows 10 drivers???
          fsadough

          We are currently offering Windows 10 drivers. Just to let you know the CC/CAD/Medical/Entertainment markets or even OEMs have not come up with the Windows 10 certifications yet, so a FirePro driver for their needs has not been requested obviously.

                     
          Windows 10 (Beta) driver for AMD FirePro is posted  now at Drivers + Download Center.

          You can download the driver under “Manually Select Your Driver” as follows. 

                       
          Step 1. Select “Workstation Graphics”             
          Step 2. Select “FirePro BETA Driver

          Step 3. Select your product for example,  FirePro W9100

          Step 4. Select “Windows 10 (32 Bit/64 Bit)” as Operating System 

            • Re: Firepro Windows 10 drivers???
              enjoiskaterguy

              Beta?  ......dudes!?  Now come one guys!  I do appreciated the reply and justification as to why users aren't seeing a full certified driver package though.

               

              Anyway, the webpage doesn't advance when I select all the required fields under 'Manually Select Your Driver; 'on Chrome as of today.8-6-2015 (Version 44.0.2403.125 m)

               

              I'll try Edge next.

               

              Anything nifty about the this BETA driver?

              • Re: Firepro Windows 10 drivers???
                sambul38

                WHQL driver 15.201.2401 is already posted, but Release Notes say it doesn't support 10-bit pixel output. I've FirePro V4900, and with the 10-bit setting ticked in AMD Control Center - FirePro GPU and 10bpc selected in AMD CC - LCD Display Color Properties, I got black screen on a 4K 10-bit color monitor. When Win 10 64-bit 10-bit supporting drivers are going to be released?

                 

                Or, can you suggest an earlier FirePro driver release for Win8 or 7, which can install and support 10-bit pixel output in Win 10 64-bit?

                • Re: Firepro Windows 10 drivers???
                  giordano.ceccarini

                  I can not find Driver for Windows 10 for my card FirePro M6000 Precision M6700.

                  Will be available soon?

                  Regards

                  Giordano

                    • Re: Firepro Windows 10 drivers???
                      jschoenwald

                      I just got automated update of driver for my Windows 10 FirePro M6000 on Precision M6700... it did not fix the only problem I have, which is:

                      every 60 seconds the graphics reset [ screen blinks once, menu-display or other (overlays?) are dismissed, window focus is lost ...].

                      Is this your problem too? Is there any known fix?

                      Thanks,

                      Justin

                        • Re: Firepro Windows 10 drivers???
                          giordano.ceccarini

                          At the moment my system working properly, I found this way.

                          Install Win 10 64 bit from clean installation. With internet connected windows update found all driver for M6700.

                          After that Graphics card is recognized like M6000 FirePro with driver.

                          Uninstall this driver and start autodetect from AMD. This recognize the cad like HD7xxx0; you can install the driver for this card and eerything is ok.

                          Please let me know

                          Giordano

                            • Re: Firepro Windows 10 drivers???
                              jschoenwald

                              At this point, AMD AutoDetect says I have AMD Radeon HD 7800M Series graphics hardware, so I guess I've already done the equivalent of what you suggest.

                              Using the HD7800M or the FirePro M6000 (FireGL V) results in the same 1-minute blink.

                              I did do an update from Windows 7 to Windows 10.. not a clean install.

                               

                              Has the symptom I describe above been seen by anyone else? Any idea how it happens?

                               

                              Thanks,

                              Justin

                                • Re: Firepro Windows 10 drivers???
                                  giordano.ceccarini

                                  Never saw the sypthom that you describe. I install all the time from clean

                                   

                                  Inviato da iPhone

                                   

                                  Il giorno 07 gen 2016, alle ore 20:05, jschoenwald <amd-external@jiveon.com> ha scritto:

                                   

                                   

                                  Community

                                   

                                  Firepro Windows 10 drivers???

                                  in AMD ProGraphics Technologies

                                  At this point, AMD AutoDetect says I have AMD Radeon HD 7800M Series graphics hardware, so I guess I've already done the equivalent of what you suggest.

                                   

                                  Using the HD7800M or the FirePro M6000 (FireGL V) results in the same 1-minute blink.

                                   

                                  I did do an update from Windows 7 to Windows 10.. not a clean install.

                                   

                                   

                                   

                                  Has the symptom I describe above been seen by anyone else? Any idea how it happens?

                                   

                                   

                                   

                                  Thanks,

                                   

                                  Justin

                                   

                                  Reply to this message by replying to this email -or- go to the message on Community

                                   

                                  SHARE THE LOVE! Help other developers by marking replies to your questions as Helpful or Correct. If you are the original question asker, you can mark replies as Helpful or Correct by:

                                  Go to the message on Community (you’ll need to log in).

                                  Click on either the Helpful Answer button or the Correct Answer button.

                                  Pat yourself on the back! You’ve helped others who have the same question as you by telling them which replies are helpful and correct.

                                  This email was sent by Community because you are a registered user.

                                  You may unsubscribe instantly from Community, or adjust email frequency in your email preferences

                                  >

                          • Re: Firepro Windows 10 drivers???
                            adiaero

                            I have a FirePro V5900. I tried all of the above but none of them worked BUT I was able to stumble upon some links from the ones suggested. Thanks. What worked for me was this driver matrix (Pretty much has them all):

                            Workstation Graphics Drivers

                            Then the Win10 Driver that actually worked (specific to my V5900) was this:

                            Detail

                            Hope this helps.