AnsweredAssumed Answered

Catalyst 15.7 won't regognize video card

Question asked by melor on Jul 23, 2015
Latest reply on Jul 25, 2015 by melor

I cannot get latest catalyst 15.7 on my computer – no matter what I try.

I have 2 Gigabyte rareon 7970GHZ edition video cards on my computer. From the beginning I've been plagued with the issue of getting some catalyst versions installed or recognizing these cards.


I've removed old drivers with drivers fusion – not helping


I've done that in safe mode – not helping


I've tried ati clean tool and used programs like cleaner to and tuneup to clean my registry – not helping


I've removed other card and tried the installation with just one – not helping


I've tried with both cards – not helping


I've tried different BIOS settings including factory defaults – not helping


I've tried different BIOS versions including defaults that my motherboard came with and now latest – not helping


I've installed windows clean and then tried latest catalyst drivers – not helping


I've done these that I just mentioned and more so many times that I've lost count – nothing helps :(((


My motherboard is: ASUS P8Z77-V LX

 

CPU: INTEL Core i5-3570 K

GIGABYTE Radeon 7970 GHZ Edition

16GB DDR3 memory

Windows 7 64 bit home premium (with latest updates)

 

I'm so fed up and frustrated to this issue that I'm ready to change to NVIDIA . Only thing preventing me of doing that is my financial situation and prizes of video cards at the moment.

Can any one help me? Is there something more I could try? Have I missed something?

Outcomes