AnsweredAssumed Answered

Intel / ATI PowerXpress & fglrx

Question asked by natasha on Jul 13, 2015
Latest reply on Apr 9, 2016 by natasha

I have a notebook Lenovo IdeaPad G500A (59-381065) with Intel HD Graphics 4000 and AMD Radeon HD 8750M videocards (PowerXpress technology):

# lspci -nn | grep 'VGA\|ATI'

00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09)

01:00.0 Display controller [0380]: Advanced Micro Devices, Inc. [AMD/ATI] Mars [Radeon HD 8670A/8670M/8750M] [1002:6600]

 

I use Linux openSUSE 13.1. Tried also openSUSE 11.4 -- 12.3, Ubuntu 12.04, Debian 8 Jessie, the same result.

 

Graphics doesn't start on the discrete AMD card with fglrx driver (tried all 13.8 -- 15.7 versions of fglrx):

<6>[fglrx] Try to set gart size 2697M failed, should be within 0M and 0M. Discard the setting. in dmesg

and

(EE) fglrx(0): Failed to open CMMQS connection. in Xorg.0.log.

Seems the former error is the reason of the later one. Here are full Xorg.0.log and dmesg corresponding to 15.7-th driver (it was installed executing .run file of the driver from 3-rd runlevel).

 

Could anybody help me to obtain properly working fglrx driver on my system, please?

 

Any help is appreciated.

Response by AMD staff is particularly highly appreciated.

 

-------------------------------------------------------

 

Corresponding bug-report: Bug 1019 - Failed to start X.

Very similar bug-report (in fact the same bug, but with a bit other models of cards): Bug 1152 - *ERROR* CMMQS initialization is failed on AMD Sun PRO [Radeon HD 8570A/8570M].

 

There are a lot of such unsuccessful tries to run graphics with fglrx on such systems. Some of such tries are listed here (+ active tries to get it working with ROSA Linux: Проблема с видео на Sun PRO [Radeon HD 8570A/8570M] (in Russian)).

 

However, some similar systems do work with AMD proprietary driver: Olav from openSUSE forum: AMD / Intel drivers problem uses dedicated AMD card without any problems... But why fglrx driver cannot work on my notebook???

 

In Release Notes to the latest (15.7-th) driver AMD signed among new features that "AMD PowerXpress support for laptops equipped with Intel 6th generation (Skylake) CPUs".

But what about other generations of processors (3-rd Gen, in my case)?

 

-------------------------------------------------------

 

Regards, Natalia

Outcomes