AnsweredAssumed Answered

Crossfire X option disappeared after update to 15.6 Beta CCC.

Question asked by ataylor92 on Jul 3, 2015
Latest reply on Jul 3, 2015 by savagebeastzero

System Specifications :

 

Gigabyte ex-58 ud3r mobo

Intel Core i7 930 OC to 4.0ghz

12 Gig DDR3 @ 1600Mhz

AMD R9 280X gigabyte windforce edition

AMD R9 280X XFX black edition

3 120 Gb Kingston SSD's

1 500 Gb samsung HDD's

Corsair 850 watt semi modular PSU

 

 

I have been using this build with the single R9 280x gigabyte for over a year now with no problems whatsoever when running windows 7 64 bit.

I recently purchased a BRAND NEW AMD XFX r9 280x just over a month ago as the have dropped in price and my motherboard is crossfire X compatible, so I purchased it on the idea of it being a nice little upgrade (I'm currently only running a 24 inch 1080p monitor, so 2 280x's i assumed would crush most games I threw at it).

 

I then performed a fresh install of  legitimate windows 8.1 x64 and as my internet connection was down, I was left to use the driver CD that came with the new XFX card; I installed these drivers (the driver version is catalyst version 13.9) - and  the install went ahead with no problems, restarted, and found everything was working as expected, there was a crossfire X tab that had the options "enable crossfire X" and "Enable crossfire X for applications that do not have a profile" (or something along those lines) - great I though, everything's working absolutely fine. When my internet was back up and running i updated the drivers to the currently latest 15.6 beta drivers , did the restart, and upon restarting I found that the button for Crossfire X under the 'Gaming' and 'Performance' tabs has now disappeared.

 

Things worth noting that I have done already and things I can confirm are correct and true:

 

     - Both cards work fine individually and in different slots

     - Windows detects both cards in device manager and both have the same driver software installed

     - When 13.9 was installed, the crossfire X function worked absolutely fine; I could even change the individual clock settings and fan speeds with AMD overdrive

     - I have attempted to roll back to EVERY PREVIOUS VERSION right down to 13.9 - which works fine, the rest do not show the Crossfire X option under the gaming and performance tabs.

     - The power supply is brand new, and after performing supply power requirement checks across various websites, I have more than 100 watt overheard.

     - I have taken steps to both remove the AMD software bit by bit using your uninstaller and also done a full uninstall of ALL AMD software using your uninstaller and re-installed the drivers; all to no effect.

     - The crossfire bridge works fine - I have tried more than one (as one came with the gigabyte card and one with the xfx card) and also tried them in different slots.

    

 

 

I simply cannot understand why this is the case. And i cannot use the 13.9 drivers as they are so sorely outdated , none of the modern games i want to play are playable with the 13.9 drivers (BF4 / Advanced Warfare / Project Cars and many other AAA games are beyond unplayable and riddled with frame drops due to out of date graphics software I assume).

 

Please understand that this is beyond infuriating as I have just spent around £400 on a new card and a new PSU just to find it doesn't work properly. I assume there MUST be some way of fixing this?

 

 

ANY help would be appreciated; I'm starting to pull whats left of my hair out.

Outcomes