AnsweredAssumed Answered

Chipset AMD A78 FCH not working (USB3.0/DVD-drive etc. not working) in Vista 64-bit

Question asked by krs000a on Jun 29, 2015
Latest reply on Jul 1, 2015 by krs000a

Hello,

I recently purchased a new computer from HP. It came with Windows 8, which I don't like. I installed Windows Vista Ultimate 64-bit as that is my favorite OS.

I navigated AMD's drivers on their site, and downloaded the installation pack for this chipset AMD A78 FCH and selected the Vista 64-bit one.

However, I'm having several issues with the motherboard's different features. First of all, the USB 3.0 ports are not working. All USB 2.0 ports work.

Also, the DVD-drive is not working. Someone said to me that this should not require special drivers, but use a standard driver that comes with Windows or the chipset.

I know these hardwares work fine in Windows 8 and 7, because I have tried both. If the AMD website has a special installation package for Vista 64-bit, why would it not work in my brand new PC then?

I know I installed the right drivers.

In Device Manager there are yellow exclamation marks next to the "hp DVD A  DH16AFSH SATA cdRom Device" and two "Unknown devices" (the USB 3.0 ports on the front and the back, I asume). I have tried installing the drivers manually too, from Device Manager, by navigating to the temp folder that AMD Catalyst creates during install, but it just says Windows is already running the correct up to date driver (well, obviously not since it's not working!).

The hardware IDs in device manager are:

the DVD-drive: SCSI\CdRomhp______DVD_A__DH16AFSH_DHH4

the USB3.0 ports (both have the same hardware ID): AMDUSB30\ROOT_HUB30&VID_1022&PID_7814&REV_0009&SID_2B35103C

 

Please, someone help!

Outcomes