15 Replies Latest reply on Nov 28, 2016 12:04 PM by component_actual

    Witcher 3 Stuttering Fix!!!

    dutcher_butcher

      Hi all.

       

      Thought I'd make a new thread for this issue.

       

      For the 'Crossfire Flickering Fix!!!' go here Witcher 3 Crossfire Flickering Fix!!!

       

      So...I'll order the fixes in order of most likely cause/relevance, and a short description below it.

      Below that I'll put my settings, these are just suggestions, specifically for a 280x (that's my card).

      For any change in 'user.settings' file to take effect you must 1st delete 'user.settings.bak', do this every time you make a change.

      I would also suggest making a backup of this file, it is located in your 'My Documents/Witcher 3' folder.

       

      1.Turn on the mouse cursor setting in graphics menu.

         (Some sort of mouse smoothing setting)

       

      2.Lower the 'Character LOD distance' in user.settings under 'Rendering/TextureStreamingCharacterDistanceLimit='

         (This is the distance at which the higher resolution texture files for characters get rendered)

         (Mine is set at 25, and I'm not getting any pop-in with this setting)

       

      3.Lower the 'General LOD distance' in user.settings under 'Rendering/TextureStreamingDistanceLimit='

         (This is the distance at which the general textures like walls fences etc. get rendered)

         (Mine is set at 20000, don't go too low for this one or you will start to notice pop-in)

       

      4.Lower the 'Character Heads LOD distance' in user.settings under 'Rendering/TextureStreamingHeadsDistanceLimit='

         (This is the distance at which the higher resolution texture files for character's heads get rendered)

         (Mine is set at 5, again no pop-in with this setting)

       

      5.Raise the 'Texture Memory Budget' in user.settings under 'Rendering/TextureMemoryBudget='

         (This is the amount of v-ram the game assigns for texture handling)

         (Mine is set to 1014, but be very careful with this as a higher value than your card can handle will hard-crash your pc, 1014 is fine for 3gb cards.)

         (But should you experience instability it's probably this setting, if that's the case just revert to the default value of 800)

       

      6.'Flip Queue Size' in RadeonPro under Advanced just tick the box and change it to a higher value (0-5).

         You need to create profile for witcher3.exe 1st, then right-click and 'Disable API Monitoring'.

         (This determines how many frames the GPU renders ahead of displaying it)

         (My setting is at 2, if you go too high (e.g. 5) you might get input lag (slower reaction to button presses and mouse movement))

       

      7.Make the 'witcher3.exe' run at high priority. Run The Witcher 3, when at the menu ctrl-alt-delete and Open 'Task Manager' under 'Processes' right-click witcher3.exe 'Set Priority/High'.

         (This determines which process is more important than others currently running)

         (I set mine at 'High', but avoid the 'Realtime' setting...this will cause instability)

       

      If your GPU can handle it you can also force FXAA in RadeonPro, for those that want more eye candy :-).

       

      You don't need to try them all if you don't want to, 5-6 and 7 aren't that important but do make an overall difference.

      It's also generally a good idea to always run a game as administrator, and take ownership of the entire Witcher 3 install directory.

       

      I've tested this with and without Crossfire on a 280x.

       

      If you're still having problems please describe the problem as accurately as possible, include CPU/GPU info, and I will try to help.

        • Re: Witcher 3 Stuttering Fix!!!
          Cornugon

          Hi there, good job on the list of tips!

           

          For me however, changing the Flip Queue Size and/or raising the available texture VRAM, and increasing process-priority doesn't reduce stuttering unfortunately (on CFX'd R9 290X). I might try those streaming LOD distance settings, since I DO think the stuttering is caused by streaming issues, even though it's not as bad at all on single-GPU. Thanks!

          EDIT: reducing the streaming distances didn't change a thing for me

           

          And I have to say it: FXAA and eye candy in the same sentence *shudders*

          FXAA is just a blur-filter which as a side effect happens to anti alias. I personally hate it since I think it's too blurry. I even rather have no AA than FXAA.

          However, the 'if your GPU can handle it'-part can be left out, since FXAA costs nearly no effort by the GPU at all (SMAA on the other hand...).

          Since you're on 280x, I suggest you try a VSR resolution instead, and maybe enabling the in-game AA to get rid of the crawling pixels (since no injecting software at all can enable Temporal AA for AMD at the moment). Well, unless you like the blur ofcourse .

          1 of 1 people found this helpful
            • Re: Witcher 3 Stuttering Fix!!!
              dutcher_butcher

              I know it's blasphemy, but that was in comparison to the broken AA before beta 15.7.

              And injecting msaa wasn't working correctly.

              Also if you upped the sharpening, it didn't look much different...well at least for this game.

               

              Unfortunately I'm running Eyefinity at 5040x900, and since I would like more than 30 fps VSR isn't really an option for me.

              I'm now using the CCC msaa at x8 (in-game off), no artifacting since 15.7.

               

              There's still some stuttering for me too though much lessened by the LOD fixes above.

              Mostly in Skellige and Novigrad (at the temple).

              I don't actually have any more leads than the above atm, but when 1.7 comes out I'll give it another shot (hopefully it won't be needed).

              I'm mostly just glad the flickering is gone, that would have been a game breaker for me.

            • Re: Witcher 3 Stuttering Fix!!!
              dutcher_butcher

              Here's another one to try

               

              Witcher 3 - Hitching and Stutter Lag in Patch 1.04 (PC) - YouTube

               

              Read the description and experiment with the numbers.

              • Re: Witcher 3 Stuttering Fix!!!
                dutcher_butcher
                1 of 1 people found this helpful
                  • Re: Witcher 3 Stuttering Fix!!!
                    Cornugon

                    Not really, that article suggests limiting the fps to 30, and using Borderless Windowed. While I can understand it will help with the smoothness, both 30fps and Windowed aren't an option for my CFX setup.

                     

                    And additionally: the 1.07 patch released yesterday did nothing to improve Crossfire stutter.

                     

                    Again my issue is that when enabling Crossfire, the game begins to stutter at 1440p+ resolutions and/or hairworks enabled, the more eye-candy, the more stutter, even with an fps of 50-60. The stutter 'feels' like streaming/caching issues and is experienced mostly while in motion (and even while going back and forth the same 10 meters). However tweaking various streaming settings, or changing any .ini settings does nothing to help here. Disabling Crossfire eliminates this stutter, but effectively cuts the framerate in half (obviously).

                    1 of 1 people found this helpful
                      • Re: Witcher 3 Stuttering Fix!!!
                        dutcher_butcher

                        The article was more for the other fixes they mentioned, so people have more options.

                        And I was getting kinda tired of getting nowhere with this.

                         

                        1.07 didn't fix squat, I agree with you there.

                        How can a game be this well designed, yet so poorly optimized?

                         

                        And don't believe the hype that's going around on the web.

                        The graphics in this game are good, but by no means do/should they warrant an upgrade from say a 280x/290x.

                        They are not next gen graphics that desperately need new gpu's, the grass for instance is still 2d plane based instead of 'next-gen' procedural.

                        And even then it looks crap, I've had waaaay better grass in Skyrim along with 700+ graphical mods and was still able to run it at 45fps at 5040x900.

                         

                        The lighting system also completely sucks.

                         

                        Gameworks bog it down, but that's just on the surface, the game is just horribly optimized for pc.

                        Many people actually believe these are next gen graphics, I guess being starved of good games tends to do that.

                         

                        I wanna love and hate CDPR at the same time.

                         

                        The changelog for 1.07 actually mentions the streaming issue, and was supposed to fix it.

                        It didn't...I'm also getting that, and it get's worse at higher resolutions, and then again with eyefinity.

                        So atm I'm getting 4 different types of stutter.

                         

                        1.The frame drops/ bad optimization/streaming

                        2.The Xfire stutter

                        3.Higher than 3k Resolution stutter.

                        4.Eyefinity sync?!?

                         

                        Even if I run this game on a single gpu, single screen and at 30 fps lock, it still stutters like hell.

                        The only stutter you can 'remove' atm is the mouse input, by turning on mouse cursor.

                        The only stutter you can 'alleviate' is the Xfire one (flip queue size), but it still doesn't remove it completely.

                         

                        The only playtime I've been able to stomach is when I'm not running or fighting.

                        I know it's ridiculous, for a game like this.

                         

                        We've got a storage chest great!!!....Not

                        There is still a much easier way to store all your items, by using the item weight modifier mod.

                        There's not even the need to go find the chest, it's all in your inventory.

                         

                        So how about something that's actually needed like a performance patch instead of random crap we don't need.

                        'Free DLC'.... freaking great...uh how about 'free performance', it's what they should've been focused on from day one.

                         

                        Sorry about the rant and wall of text, but I figured others need to read this.

                          • Re: Witcher 3 Stuttering Fix!!!
                            Cornugon

                            I personally love the lighting in the game. But that's just me. The actual 'next gen'-thing I'm missing is world tesselation. Still I don't think the game looks bad at all, but performance could be better.

                            The changelog lists many bug- and quest-fixes which are always useful even though I didn't encounter many of them. I also think the book tab is useful, as are the weightless crafting ingredients.

                            And there are two hairworks options added to the graphics options.

                            1 of 1 people found this helpful
                        • Re: Witcher 3 Stuttering Fix!!!
                          salvolin

                          I read that pcgamer.com thread you mentioned. At first it's rather academic, but in the end it gave some advice that worked for me.

                           

                          Start RivaTuner Statistics server (I already had that installed since I am using msi Afterburner for showimg my FPS)

                          That it said. Add a profile for witcher.exe and just set a max FPS.

                           

                          Worked for me to remove "most" of the stuttering. I set the FPS in RivaTuner to 60 even though I only manage to have 50. Still worked for me.

                          I must admit though that just working with one GPU instead of 2 gives me a smoother gameplay with 30 FPS.

                           

                          I guess CDPR and AMD still have room for improvement.

                           

                          As a manner of principle I just can't go playing with only one GPU... so I am going for the RivaTuner solution for now.

                           

                          I Guess Riva Tuner helping me play Gerald of Rivia is probably just how it's meant to be.

                          1 of 1 people found this helpful
                            • Re: Witcher 3 Stuttering Fix!!!
                              salvolin

                              Like I said in that previous post. A bit of stuttering still remained. I tried playing on my 200hz TV through DVI and the screen was as smooth as it gets. So as a long shot I had my internal 60hz laptop screen replaced by a 120hz one (yes I had a laptop screen replaced to play this game..., hell I bought a crossfire laptop to play the game to start with :-) )

                               

                              And guess what. Stuttering / screen tearing is now almost gone.

                              Further more I set my max FPS to 110 with RivaTuner. This fixed the flickering of inventory items.

                               

                              Now I only have some flickering remaining in:

                              1. Leader cards during gwent
                              2. Win Loose (gems) during gwent
                              3. Messages in message boards
                              4. Character abilities in the game menu (where you can spent the points)

                               

                              Any ideas to fix that to are welcome.

                               

                              (

                              1 of 1 people found this helpful
                          • Re: Witcher 3 Stuttering Fix!!!
                            snapambush

                            wow thanks mate this is amazing fixed a lot of my issues, still have a problem with the game when I move forward I have a slight lag. its weird because it only happens when i move not when i am stationary even though im running at a constant  60 fps it still has that problem, i am sure it has to do with the actual game not with my setup.

                            1 of 1 people found this helpful
                              • Re: Witcher 3 Stuttering Fix!!!
                                dutcher_butcher

                                I'm glad it eased your stuttering somewhat.

                                 

                                I have not been able to completely remove the stutter you mention.

                                As far as I know it's a frame-time stutter, frame caps help a little but not much, even at half the refresh rate etc.

                                 

                                The best result I've been able to get is to apply the fixes above and use Rivatuner to set a frame limit.

                                Rivatuner tries to equalize the frame-times, but doesn't quite get it right, still better than a regular cap (e.g. RadeonPro) and tons better than the built in framerate limiter.

                                If you decide to try this, set the fps at 1-2 frames lower than your lowest when running without the built in frame cap, e.g. if your lowest fps is say 45 then set the limiter to 43.

                                 

                                Good luck!

                              • Re: Witcher 3 Stuttering Fix!!!
                                dutcher_butcher

                                For those of you who are still experiencing stuttering...

                                 

                                I'm right now (almost) stutter free, that is to say only very mild (smoother) dips, and only in heavily populated areas like the center of Novigrad, and it only happens when running.

                                I should mention also that this is with Crossfire enabled, in Eyefinity mode and at a resolution a little higher than 1440p, on (2x) 280x's and running the latest Crimson drivers as well as Patch 1.12.1

                                As soon as you disable crossfire completely that final stutter (not really a stutter anymore it's way smoother) should be gone.

                                 

                                The following are the 5 settings that made the biggest difference:

                                 

                                1.Go to your bin/config/base folder and open gc.ini

                                   Find the following line and make sure it's set at 512.

                                 

                                ; Upper limit for amount of memory used by the objects that will automatically trigger the GC
                                ObjectMemoryTrigger = 512

                                 

                                This adresses the garbage collection (removal of old object from memory) interval.

                                Now it should happen less often and when it happens it will be smoother.

                                 

                                2.Go to your bin/config/base folder and open resources.ini

                                   Find the following line and make sure it's set to 50.

                                 

                                ; The internal maximum number of pending async requests is 64 and we need to leave some slots avaiable for other systems (caches)
                                MaxRequests = 50

                                 

                                Then find the following line and set it to 50.

                                 

                                ; Maximum memory budget for compressed data
                                ; The bigger, the faster the loading
                                ; Note: the memory is not pre allocated, it's just tracked and limited
                                MaxCompressedBudget = 50

                                 

                                Do the same for the following line but set it to 125.

                                 

                                ; Maximum memory budget for uncompressed data
                                ; The bigger, the faster the loading
                                ; Note: the memory is not pre allocated, it's just tracked and limited
                                ; Note2: this should always be bigger than MaxCompressedBudget value, usually x2.5 times (average compression ratio)
                                MaxUncmpressedBudget = 125

                                 

                                3.In RadeonPro make a profile for The Witcher 3's executable (bin/x64).

                                  Go to the Advanced tab and tick Flip Queue Size, then set it to 1

                                 

                                I know it's late in the game but perhaps this is still useful to someone.

                                 

                                Also I figured out why SMAA wasn't working with RadeonPro, you need to have FXAA enabled and set to Ultra, then you can add a custom AA.

                                For some reason we can't inject other forms of AA without FXAA.

                                • Re: Witcher 3 Stuttering Fix!!!
                                  component_actual

                                  I am running 2x290x in Crossfire at 2560x1440 with a 96hz monitor. With medium setting and crossfired disabled I was only getting about 43FPS average. After enabling crossfire my FPS went up nearly 100% to about 84FPS average, however there was very noticeable micro possibly even macro stutter. Changing the framerate in the Witcher Graphics options from "unlimitted" to 60FPS pretty fixed the stutter for me. It runs perfectly smooth now at 60 FPS. I was even able to turn up the graphics settings to Ultra and still get 60FPS. I would like to use a higher frame rate setting but smooth 60FPS is better than a stuttery 80FPS in my opinion.