1 Reply Latest reply on Jun 17, 2015 3:10 PM by kingfish

    7870M no powertune/overdrive in 14.12

    leoh214

      as title says no powertune/overdrive in catalyst 14.12 in none of the drivers ive had installed shows up even tho its mentioned that its supported and the laptop is a Samsung 700G7C-T01US

      AMD Radeon HD 7870M - NotebookCheck.net Tech

        • Re: 7870M no powertune/overdrive in 14.12
          kingfish

          Your drivers are not installed properly.

           

          Your laptop is equipped with switchable graphics. In order to update the AMD driver, the Intel graphics must be the current version. Go to this Intel link, and manually ( do not use the Intel Driver Update Utility) find the latest graphics driver for your laptop, as pictured. Download and save it to your desktop. If you don't know which version of Intel graphics you have, look in device manager.

          https://downloadcenter.intel.com/default.aspx

           

           

          laptop intel drivers.png

           

           

           

           

           

           

           

           

           

          Download these AMD drivers to your desktop.

          For Windows 8.1 or Windows 7

          http://support.amd.com/en-us/kb-articles/Pages/latest-catalyst-windows-beta.aspx

           

          Now delete the Intel drivers from your computer using 'uninstall a program' in the computer control panel. Uninstall the AMD drivers from your computer using the 'uninstall a program' in the computer control panel. NOTICE IMPORTANT:

          ****Computers with Intel processors select 'express' uninstall all AMD software including the install manager.

           

          ****Computers with AMD processors custom uninstall the AMD graphics driver and Catalyst Control Panel only.

           

           

          Reboot.

          Now install the Intel drivers first and lastly the AMD drivers.

          NOTICE: If you do not want raptr/gaming evolved installed with your new drivers, select 'custom install' and uncheck the box for "gaming Evolved".

           

           

           

          AMD.png