suboba

Driver/runtime, OpenCL version & supported devices

Discussion created by suboba on Jun 17, 2015
Latest reply on Sep 1, 2015 by pinform

Okay so this is a continuation of : Installed AMD APP SDK 2.9.1 but got OpenCL 2.0?

I don't know why, but I'm not able to reply to my own thread, so I'll make this thread.

 

I have AMD GX-210HA w/ Radeon HD Graphics which I THINK supports OpenCL 1.2  : http://www.amd.com/Documents/AMDGSeriesSOCProductBrief.pdf

It is part of this Gizmo 2 SBC.

 

I installed the latest driver for this hardware and got the results in my previous thread:  OpenCL 2.0 for the gpu and OpenCL 1.2 for the cpu. (see previous thread).

Now according to bsp2020's response to my previous question, the driver you install contains the OpenCL runtime that will run on the gpu.

 

learning that the driver contains the ocl runtime, I tried to install an older version driver that I hoped would contain an ocl 1.2 runtime - not ocl 2.0  .   Unfortunately, it seems that I'm not able to install any previous version / older drivers for this hardware(I keep getting an error about X server not supported), thus there is no way I can get a hold of the ocl 1.2 runtime which my device supports.  The latest driver works, but gives me ocl 2.0 on hardware which is supposed to support ocl 1.2.  Consequently, when I try some sample programs, choosing the gpu actually results in slower results.  My guess is because the runtime/driver does not match the hardware which is supposed to support 1.2. 

 

So my questions are: 1)  can you use OpenCL 2.0 on a device that supports ocl 1.2?  ( I would think not).

2) Running clinfo ( see previous thread) reports that the gpu is getting ocl 2.0 runtime.  How can this be if the device does not support that version of ocl?  Thus, I tried to install an older version of catalyst, but wasn't successful.

 

This might be a long shot, but could AMD just tell me/ provide me the exact driver version and APP SDK for this product so I could finally do some ocl development?  I specifically purchased this Gizmo 2 board just for the OpenCL capability, and now it seems I can't use it!

 

Please, any help would be appreciated.

Outcomes