1 Reply Latest reply on Jun 17, 2015 8:53 AM by kingfish

    Error message on login with ATI Radeon HD 3400

    cobramike

      I just purchased a refurbished HP Z400 Workstation with an ATI Radeon HD 3400 Video adapter. 

      I get an error message on boot and login. (MMLoadDrv:MMLoadDrv.exe - Bad Image

      C:|Windows\System32\atipdlxx.dll is either not designed to run on Windows or it contains an error.

      The OS is Windows 7 Pro x64 and the display appears to be working ok. Has anyone run into this?

      I have un-installed the drivers and tried different versions but get the same error.

       

      Thanks, Mike

        • Re: Error message on login with ATI Radeon HD 3400
          kingfish

          Have you installed the relevant 'optional' Windows Updates? This is a must with Win7, especially in the .netframework area.

          Here are the last drivers available for your graphics card:  Legacy

           

           

          There are different ways to install AMD driver updates on desktop computers. Some users just install the new drivers over the old drivers and have no issue.

           

          There are some driver updates that require you to uninstall the existing drivers before you install the new....and this method is used by many (including myself) to install any driver, whether is required or not.

          First download your drivers to your desktop here using steps 1-5 manually .....Do Not use automatic find and install

          Use the computer control panel 'Uninstall a Program'

          Select AMD Install manager:

           

          ****  For computers with Intel processors > select 'express uninstall all software including the install manager. Reboot. Install new drivers. Reboot.

           

           

          ****  For computers with AMD processors > select the graphics drivers and CCC ONLY to be uninstalled. Reboot. Install the new drivers . Reboot.