63 Replies Latest reply on Jul 19, 2018 7:36 AM by biggun1460

    Witcher 3 Crossfire Flickering Fix!!!

    dutcher_butcher

      Hi everybody.

       

      After many days worth of digging through forums and trying .ini tweaks, I have finally pinned down the cause of the water, metal and distant walls flickering when running Crossfire.

      I noticed the flickering was most noticable in distant windows walls and water, and only affected items which were hit by sunlight and not the light from flames.

      Lightbulb! Must be the lighting right? But there are no lighting tweaks, so I messed with the next best thing, namely the shadows.

       

      I had already used RadeonPro to flip the Queue Size, this made things a bit less noticeable, but didn't fix the flickering completely.

      I'm currently back on the default Queue Size, but this fix works with and without the Queue Size tweak.

      Also delete any profile you may have made in CCC, and disable AA (bin/config/base) in rendering.ini just set temporal to false.

      If you want SMAA you can force it through RadeonPro or Sweetfx 2.0+Reshade (doesn't work with 1.5 and the toggle doesn't work with either).

      If you use RadeonPro for the SMAA and the game refuses to launch, just right click and disable API Monitoring and Auto-Detection.

       

      Go to your 'My Documents/Witcher 3' folder and delete user.settings.bak (don't worry this is just the backup file).

      Do this every time you wish to change a setting, or it will not be saved and the above file just overwrites any changes you've made.

       

      Now open user.settings with notepad.

      Scroll down to the 'Rendering' section.

      And just change 'CascadeShadowDistanceScale2=' to a value of 1.7 (Ultra is 1.5 by default).

       

      This changes the quality of the shadows rendered in the distance, and if your rig can handle it you should be able to go even higher.

      Although I doubt that's needed since 1.6 left some very light flickering and 1.7 got rid of it all together.

      Note...sometimes when entering the world the game may crash, happens about half the time.

      If you get past this every thing is stable.

       

      However since I can only speak for myself, I would like some responses from people with different GPU/CPU setups.

      Just so people have some idea of where their settings should be at.

       

      Please provide GPU/CPU info and off course the value you're running best at.

      Other specs like game/driver/os version could also prove useful.

       

      Mine are...2x 280x/fx8350 at 1.7.

       

      Other Specs...Witcher 3 Patch 1.05/AMD 15.5 Beta drivers/Windows 7 Ultimate x64

       

      In-Game every thing is on ultra except AA which is off.

      I've also noticed the fps limiter makes the greatest impact on the stuttering.

      For me it's silky smooth at 30 and slightly choppy at 60 but nothing major.

       

      Hope this works for you guys/girls, and please take the time to report back if you get this working.

       

      P.S. Sorry for the wall of text, but I though I aught to be thorough.

      P.P.S This is my 1st thread on the AMD forums, so sorry in advance if this is in the wrong section or something.

        • Re: Witcher 3 Crossfire Flickering Fix!!!
          mrfury

          Awesome!!! I still notice a small amount of flicker in the city, but this reduced the flicker to almost nothing.  Thanks for the research.

          1 of 1 people found this helpful
          • Re: Witcher 3 Crossfire Flickering Fix!!!
            rathemeck

            Sadly, I tried this fix last night, it worked, kind of.  I still have a lot of flashing in cities and around water.  I have not patched the game so I'm going to try that first then report back.

             

            My specs: FX8320 w/ 2 x XFX 7870 DD Ghz Edition Cards.

             

            Thanks for the effort though!

            1 of 1 people found this helpful
              • Re: Witcher 3 Crossfire Flickering Fix!!!
                dutcher_butcher

                Yep... it came back for me as well a few days ago.

                It's really a shame, it was running absolutely beautifully.   

                 

                It's less for me after meditating, but for some reason this only works once, until the next system restart.

                The flickering is back with a vengeance, for the grass, water and walls, strangely enough the metals like sword hilts and candlesticks don't flicker anymore.

                I'm currently back to running without Crossfire.

                 

                As for patch 1.06 judging from the patch notes it doesn't seem to fix anything even slightly related to Crossfire.

                And from what I understand, the ball is in CDPR's court, and off course they're gonna fix SLI before Crossfire.

                Shame on CDPR for selling out to those Nvidiots, also AMD dropped the ball on this one...Tressfx/Mantle anyone?

                If there ever was a game where these would shine (pointing at you AMD), then this was it!!!

                 

                Still the game is fun, but I'm shelving it for now.

                The ini tweaks are making little if any difference atm, and we need more from CDPR if Crossfire is ever gonna be fixed.

                Unfortunately the CDPR forum have locked any thread asking about patch ETA's, and have so far given absolutely no answer to any questions in relation to Crossfire (As opposed to the dozens of responses concerning SLI). Making it pretty obvious what their priorities are.

                  • Re: Witcher 3 Crossfire Flickering Fix!!!
                    rathemeck

                    I wouldn't put it down just yet. I am running the game on a single card, waiting for DX12 in July and possibly a new driver set in the coming months.

                     

                    I'm getting decent frames. I have mostly everything on High except for texture which I have set to ultra and with everything turned on in post processing.  With those settings I'm still getting 35-45 fps which isn't bad for a XFX HD 7870 GHz card.

                     

                    I may try thehairyfoot's fix up to 1.9 although I'm sure I'll just be sticking with a single card solution.  I've also been looking for an excuse to buy a new GPU so that may happen also.

                    1 of 1 people found this helpful
                      • Re: Witcher 3 Crossfire Flickering Fix!!!
                        dutcher_butcher

                        Yep the time for upgrades is nigh, personally I'm waiting for the r9 4xx Arctic Islands series (2016?).

                         

                        If AMD ever release an air-cooled card with 8gigs 'unified' HBM, then I'm on board, who knows maybe even crossfire for the mantle games.

                        4 gigs just isn't enough for me atm, even if it is HBM, it's just not future proof enough, especially if you mod games to the breaking point.

                        *Cough* Skyrim anyone?

                  • Re: Witcher 3 Crossfire Flickering Fix!!!
                    thehairyfoot

                    I tried this: I saw some improvement; not all.
                    I even bumped up the value from the suggested 1.7 to 1.9 and got more improvement.
                    It's well worth trying this though: it lessens the problem from game-breaking in some areas to just an momentary annoyance.
                    My setup: i5 w. 2 X R9 280 OC to 1050mhz

                    2 of 2 people found this helpful
                    • Re: Witcher 3 Crossfire Flickering Fix!!!
                      amd_user

                      I have Fx8320 + 2x7950 and have horrible flickering also. Tried your solution but didn't fix my problem. I hope 15.6 fix that problem.

                      1 of 1 people found this helpful
                      • Re: Witcher 3 Crossfire Flickering Fix!!!
                        dutcher_butcher

                        Ok, I can't seem to edit the original post.

                        I have now managed to get rid of every kind of flickering, water, puddles, windows, shadows, walls, grass, foliage etc.

                        The only exception being the mini-map and inventory mouse-over flickering, although it is much less than before and gone after a second mouse over (for the inventory at least).

                        I'll make this simple, kinda :-s.

                         

                        1. Go to Witcher 3/bin/config/base and open 'rendering.ini'.

                            Set 'EnableTemporalAA=' to false.

                            This disables in-game AA as it causes flickering, don't freak out keep reading ;-).

                            Here you can also adjust the Hairworks AA level for better performance.

                         

                        2. Go to Witcher 3/bin/x64 and rename, move or delete 'APEX_ClothingGPU_x64.dll'.

                            This applies some sort of physx affect to clothing, I haven't seen a difference since renaming it.

                         

                        3. Go to My Documents/Witcher 3 and delete 'user.settings.bak'

                            Do this every time you make a change.

                         

                        4.Now open 'user.settings' with Notepad.

                           And just change 'CascadeShadowDistanceScale=' to a value of 1.9 (Ultra is 1.5 by default) (1.9 was suggested by 'thehairyfoot', and has better results than 1.7).

                           Do this for all of them they range from 0 to 3, (0,1,2,3 so 4 in total).

                         

                        5.Open RadeonPro, make a profile for The Witcher 3.

                           Right click it and disable 'API Monitoring'.

                           Now go to the 'Visual' tab.

                           If you want AA just check FXAA and set to Ultra, (SMAA works as well but with heavy artifacting).

                           Scroll down and set Tesselation Control to x4 x8 or x16, (improves fps when hairworks is on).

                           Now go to 'Advanced' tab.

                           Check 'Flip Queue Size' and set it to 0, (higher settings cause input lag).

                          

                        6.Open CCC, (right-click desktop, the top one).

                           Make sure that under 'Gaming/3D Application Settings' there is no profile for 'witcher3.exe', if there is just delete it.

                           Don't worry the 15.5 driver has a built-in profile, that's the one we want to load.

                           Also make sure crossfire is enabled under 'Gaming/AMD CrossfireX'.

                         

                        7.In RadeonPro right-click the Witcher profile you made and run the game.

                           If when loading an old save, the game crashes on entering the world, just try again you'll eventually get in.

                           Then just meditate to a different time of day and save, after that you should be good.

                           Now open the menu and go to graphics settings, set the game to run in Fullscreen, any other mode will disable Crossfire.

                           Also do not touch the AA settings in-game, as this will undo step 1.

                          

                        And that's it.

                        As a side note...It takes about a minute for the second card to fully come online.

                        Also if the game still flickers at first, try meditating to a different time of day.

                        Please let me know if you still have problems with this.

                        I've been playing for about 4 hours and have had no in-game flickering what so ever.

                         

                        I should also mention I'm running at 5040x900 (Eyefinity), on 2x Asus 280x DCII Top (stock clocks), fx8350 (4.3ghz OC) and 32gigs of ram.

                        Turn V-sync off and set the Frame Limiter to unlimited to get rid of the stuttering.

                        1 of 1 people found this helpful
                          • Re: Witcher 3 Crossfire Flickering Fix!!!
                            rathemeck

                            Thanks for your research on this! I'll give it a shot. 


                            Just a quick question. Is RadeonPro the same thing as Raptr or is it different?  Sorry I've just never used that program before.

                             

                            Thanks again for your attention to this!

                            1 of 1 people found this helpful
                            • Re: Witcher 3 Crossfire Flickering Fix!!!
                              r1st000

                              works pretty well on 2x 7970

                              i just wonder how did you come up with that fix

                                • Re: Witcher 3 Crossfire Flickering Fix!!!
                                  dutcher_butcher

                                  I searched for days for any forum thread or Youtube video/comments containing anything related to performance/flickering or instability.

                                  E.g. The APEX fix didn't actually come from a crossfire user, but I figured any performance issues might be getting worsened by using 2 cards.

                                   

                                  I've been using RadeonPro for years, and I love modding RPG's, and you really learn new terms with each mod.

                                  I'm also a total graphics junkie, and I love tweaking games to get the most out of the hardware.

                                  Besides this game rocks, and the fact many people couldn't play it properly (including myself) was just irritating.

                                   

                                  And like I said before I love modding, but for that to work the game needs to run good 1st.

                                  I also plan on making my own mods, (grass if my knowledge allows it), so I figured I'd get acquainted with the relevant terms and files.

                                  This is basically the new Skyrim, and CDPR plan on releasing a REDkit for it.

                                  • Re: Witcher 3 Crossfire Flickering Fix!!!
                                    r1st000

                                    have to say after playing about  1h with that fix that it  still isnt perfect , yes it removes most of flicer but its still present  on some cases , it might be enough for most of players but since i have waited for complete fix from amd or cdpr for a month now i think i can wait a bit more . I just hope it does get fixed eventually by amd or cdpr

                                    1 of 1 people found this helpful
                                      • Re: Witcher 3 Crossfire Flickering Fix!!!
                                        dutcher_butcher

                                        That's strange, let's get to the bottom of it.

                                         

                                        There are still a few things you can check/change.

                                         

                                        1st...I would suggest increasing the 'Flip Queue Size', by no means are the numbers suggested an absolute must.

                                        This also shouldn't affect your fps that much. it's a trade-off between flicker (low value) and mouse lag (high value).

                                         

                                        Second...I'm running Eyefinity at over 4k, so my 'CascadeShadowDistanceScale=' is set relatively low to save on fps.

                                        So you can try also increasing these values (2.0,2.5,3.0 etc.), it really depends on the resolution you're running at.

                                         

                                        Might sound stupid but are both cards running at the same clock speeds?

                                         

                                        Have you tried running the game at maximum priority via task manager?

                                         

                                        And finally does it get worse when you overclock/underclock you cpu?

                                        Crossfire is very CPU heavy and even a slight overclock can make that crucial difference.

                                        Especially when the game hasn't been optimized yet.

                                         

                                        Also what GPU's are you using, I seem to remember something about the 285x having major problems with this game.

                                        BTW the affects of this fix are only visible after about a minute in gameplay (you need to actually be running around doing stuff).

                                        For some reason there's a delay, you should be able to tell when the second card kicks in by the fan volume.

                                         

                                        If you want me to dig even deeper, I can take a look at your user.settings file and compare it to mine.

                                        So you could try posting that here, however I would need to know which GPU you're using before advising any other setting changes.

                                         

                                          • Re: Witcher 3 Crossfire Flickering Fix!!!
                                            electricessence

                                            Man I want to give you an award.  But at the moment I can only give you an award for effort.

                                             

                                            I tried your fix, step by step.  And it still flickers.  You have to go to Novigrad and run around.  The flickering is OBVIOUS.
                                            I will say that the scaling is great!  And I want so bad to play full 3440x1440.  But alas, I've also tried everything imaginable.

                                             

                                            I'm not saying you should give up, but here's the bottom line:
                                            1) I can't flicker AT ALL not even for a brief second.
                                            2) Whatever the fix is, it can't 'stutter'.  I've noticed that any crossfire setup 'stutters' where a single card is butter smooth.

                                             

                                            I'm willing to help you test this.  But only out of morbid fascination.

                                             

                                            UPDATE:
                                            I set the RadeonPro profile to CrossFireX off, and I don't really see the scaling benefit as much as I'd like.

                                             

                                            I really wish there was a better pipeline mode like have the second GPU do all the AA and after processing or something.   Even if that's not true scaling, it would be nice to have that option.

                                            1 of 1 people found this helpful
                                              • Re: Witcher 3 Crossfire Flickering Fix!!!
                                                dutcher_butcher

                                                Hi,

                                                 

                                                I've noticed that when loading in Novigrad, it takes far longer for the second card to kick in, than say if you load in a forest somewhere.

                                                Once you spend a few minutes running around swinging and jumping, the flicker interval gets less and less and eventually disappears.

                                                The last flicker to disappear for me where the puddles.

                                                 

                                                Have you tested for more than 5 minutes in-game, without fast traveling?

                                                You also have to actually be doing stuff, standing still and waiting for the flickering to go away does nothing.

                                                 

                                                Have you meditated to reload the lighting?

                                              • Re: Witcher 3 Crossfire Flickering Fix!!!
                                                donsailieri

                                                Hey dutcher,

                                                 

                                                thank you very much for your work so far. I tried applying your tweaks so I could finally get acceptable performance from my 2 Sapphire 5870 Vapor X I have running in Crossfire (that's 2x 1024MB VRAM) on Windows 8.1 64bit with 12Gb of RAM. Game Version 1.05, Driver 15.5 Beta. Running the game at 1920x1200.

                                                 

                                                Unfortunately, your tweaks don't work for me at all, the texture flickering is as bad on DistanceScale=1.9 as it is on =5. I'm pasting my entire user.settings below for you to compare.

                                                 

                                                This is what it looks like:  http://i.imgur.com/NVPYQBf.gifv

                                                 

                                                I set the flip queue size to 2, and am running the game at Realtime priorty (through processxp)

                                                 

                                                [Gameplay/EntityPool]

                                                SpawnedLimit=100

                                                [Hidden]

                                                HasSeenDLCMessage=true

                                                HasSetup=true

                                                uiVerticalFrameScale=1

                                                uiHorizontalFrameScale=1

                                                [Localization]

                                                RequestedSpeechLanguage=

                                                SpeechLanguage=EN

                                                RequestedTextLanguage=

                                                TextLanguage=EN

                                                [Viewport]

                                                VSync=true

                                                Resolution="1920x1200"

                                                FullScreenMode=1

                                                VSyncThreshold=0

                                                OutputMonitor=-1

                                                [Budget]

                                                cvMaxAllowedLightsShadowTime=1

                                                cvMaxAllowedApexDestroTickedTime=0.2

                                                cvMaxAllowedGrass=30000

                                                cvMaxAllowedDecalsDynamic=10

                                                cvMaxAllowedDynMeshes=104857600

                                                cvMaxAllowedChunksSkinnedTime=2.5

                                                cvMaxAllowedTrianglesSkinned=100000

                                                cvMaxAllowedDecalsSSTime=0.1

                                                cvMaxAllowedLightsShadow=3

                                                TerrainTileMipDataBudget=100

                                                cvMaxAllowedApexTicked=60

                                                cvMaxAllowedActiveEnvProbesTime=0.1

                                                cvMaxAllowedStatTextures=314572800

                                                cvMaxAllowedSpeedTree=5000

                                                cvMaxAllowedLightsNonShadowsTime=0.2

                                                cvMaxAllowedSpeedTreeTime=2.2

                                                cvMaxAllowedChunksStatic=1500

                                                cvMaxAllowedTrianglesStatic=500000

                                                cvMaxAllowedHiresChunks=25

                                                cvMaxAllowedDecalsDynamicTime=0.5

                                                cvMaxAllowedLightsNonShadows=40

                                                cvMaxAllowedChunksStaticTime=1.5

                                                cvMaxAllowedChunksSkinned=400

                                                cvMaxAllowedApexDestroTicked=20

                                                cvMaxAllowedStatMeshes=209715200

                                                TerrainTileMinTimeout=2

                                                cvMaxAllowedHiresChunksTime=0.2

                                                cvMaxAllowedApexTickedTime=0.5

                                                cvMaxAllowedCharTextures=209715200

                                                cvMaxAllowedParticlesCountTime=0.2

                                                cvMaxAllowedParticlesCount=1000

                                                cvMaxAllowedGrassTime=1.5

                                                TerrainTileTimeout=10

                                                OcclusionQueryAdditionalMemory=5

                                                TerrainTileLoadingTimeout=5

                                                cvMaxAllowedDecalsSS=160

                                                [Audio]

                                                Subtitles=true

                                                [LoadingScreen/TCR]

                                                ShowProgress=true

                                                [Game]

                                                DoNotPauseWhileStopped=false

                                                [PostProcess]

                                                AllowChromaticAberration=false

                                                MotionBlurPositionTreshold=0.05

                                                AllowVignette=false

                                                MotionBlurRotationTreshold=1

                                                AllowShafts=false

                                                AllowMotionBlur=false

                                                AllowSharpen=false

                                                AllowAntialias=false

                                                SSAOSolution=0

                                                AllowBlur=false

                                                [Input]

                                                PadVibrationEnabled=true

                                                KeyboardCooldownSpeed=0.1

                                                InvertCameraXOnMouse=false

                                                InvertCameraYOnMouse=false

                                                CameraAutoRotX=true

                                                InvertCameraX=false

                                                UIMouseSensitivity=1

                                                CameraAutoRotY=true

                                                RightStickCameraSensitivity=1

                                                InvertCameraY=false

                                                RightStickAimSensitivity=1

                                                MouseSensitivity=1

                                                [DLC]

                                                DlcEnabled_dlc_010_001=1

                                                DlcEnabled_dlc_005_001=1

                                                DlcEnabled_dlc_007_001=1

                                                DlcEnabled_dlc_013_001=1

                                                DlcEnabled_dlc_004_001=1

                                                DlcEnabled_dlc_006_001=1

                                                DlcEnabled_dlc_001_001=1

                                                DlcEnabled_dlc_008_001=1

                                                DlcEnabled_dlc_002_001=1

                                                DlcEnabled_dlc_003_001=1

                                                [Gameplay]

                                                Difficulty=4

                                                [LevelOfDetail]

                                                SwarmHideDistance=200

                                                DecalsHideDistance=30

                                                DimmerHideDistance=60

                                                DynamicDecalsHideDistance=20

                                                StripeHideDistance=60

                                                [General]

                                                ConfigVersion=1

                                                [LoadingScreen/Editor]

                                                Disabled=false

                                                [LoadingOverlay/TCR]

                                                FadeOutCooldownExtraTime=1

                                                FadeInSpinnerTime=1

                                                NoninteractiveSpinnerTime=3

                                                FadeOutSpinnerTime=1

                                                NoninteractiveEndCooldown=1

                                                [Visuals]

                                                InventoryBgColorScaleB=0.036

                                                InventoryFixedLuminance=0.25

                                                InventoryBgColorScaleG=0.034

                                                GammaValue=1.9

                                                InventoryBgColorScaleR=0.02

                                                [Rendering]

                                                GrassDensity=1600

                                                DecalsSpawnDistanceCutoff=10

                                                TextureStreamingHeadsDistanceLimit=5

                                                GlobalOceanTesselationFactor=16

                                                TextureStreamingCharacterDistanceLimit=25

                                                CascadeShadowFadeTreshold=2

                                                CascadeShadowDistanceScale2=1

                                                CascadeShadowDistanceScale=5

                                                MaxTextureAnizotropy=8

                                                TextureStreamingDistanceLimit=20000

                                                MaxCascadeCount=3

                                                UseDynamicWaterSimulation=false

                                                TextureMemoryBudget=300

                                                CascadeShadowDistanceScale3=1

                                                MeshLODDistanceScale=1

                                                MaxSpotShadowSize=256

                                                ScaleformTextureUnstreamDelay=2.5

                                                DecalsChance=1

                                                TerrainReadAheadDistance=200

                                                AtlasTextureDownscale=1

                                                HairWorksLevel=0

                                                MaxTextureAnisotropy=4

                                                TerrainScreenSpaceErrorThreshold=3

                                                MaxTerrainShadowAtlasCount=2

                                                MaxCubeShadowSize=256

                                                DetailTextureDownscale=1

                                                TextureDownscale=1

                                                HardwareCursor=true

                                                TextureInFlightCountBudget=12

                                                TerrainErrorMetricMultiplier=20

                                                CascadeShadowDistanceScale0=1

                                                MeshRenderingDistanceScale=1

                                                CascadeShadowDistanceScale1=1

                                                [Input/Gestures]

                                                EnableSwipe=true

                                                EnablePan=true

                                                EnableGestures=true

                                                EnablePinch=true

                                                [LoadingScreen]

                                                FadeInTime=3

                                                SkipShowWithAnyKey=true

                                                GameRevealTime=3

                                                SkipHideDelay=3

                                                SkipInputDelay=0.25

                                                FadeOutTime=1.5

                                                SkipAutoshow=false

                                                [Engine]

                                                LimitFPS=30

                                                [Rendering/SpeedTree]

                                                GrassGenerationEfficiency=0.075

                                                GrassDistanceScale=0.8

                                                FoliageDistanceScale=1

                                                FoliageShadowDistanceScale=12

                                                GrassRingSize=4194304

                                                [Save]

                                                ShowCompatWarning=false

                                                [Kinect]

                                                Kinect=true

                                                [Foliage]

                                                MaxVisibilityDepth=8

                                                1 of 1 people found this helpful
                                                  • Re: Witcher 3 Crossfire Flickering Fix!!!
                                                    dutcher_butcher

                                                    Unfortunately I can only pin-point 1 change in your .ini file when compared to mine (which isn't related to running different GPU).

                                                    Which is that your 'FullScreenMode' is somehow set to 2, but I take it that's because you turned off full screen after testing?

                                                     

                                                    I've also checked the specs for your card, which is where I think the problem lies.

                                                    You only have 1gb v-ram, and a core clock speed of 870mhz (when not overclocked).

                                                    This probably means that the card, cannot swap out textures or refresh the effects fast enough, in fact if that's the case the flickering could even get worse for you.

                                                    Since by increasing the amount of shadows it has to render, you're asking even more of the card.

                                                    I'm sorry to say any fix I mentioned, which dictates an increased value will probably not work for you.

                                                     

                                                    The only reason I was able to get rid of the flickering is because my card had some 'room' left over.

                                                    Unfortunately the scaling isn't 100% yet, so these fixes attempt to raise the amount of stuff that's going on so that the second GPU is running within acceptable range (e.g. no flickering).

                                                     

                                                    With me, if the scaling is say 80% on GPU 2 and 100% on GPU 1, if I overclock or make both cards render about 20% more (through these tweaks, specifically shadows), then I've made up the difference. And now the scaling should be closer to 100% on GPU 2 and 120% on GPU 1, if that makes sense.

                                                    However with your GPU I just don't think you have the headroom to do this.

                                                    I think you're only hope atm is to wait for a driver update, which specifically addresses scaling, and after that a game update.

                                                    Or to consider upgrading your GPU.

                                                     

                                                    The specific symptom you linked was also present for me, but removing the 'APEX Clothing' file fixed it.

                                                    And since this was wasn't an .ini fix, I have no suggested value or setting change to give you.

                                                     

                                                    This a graphically heavy game (even on low) and frankly I think it's wishful thinking, running it on a card with anything less than 2gb v-ram (let alone Crossfire).

                                                    Also cards with more v-ram tend to come with a higher clock speed, which is definitely needed for good Crossfire performance, even more so if you want to 'FIX' Crossfire yourself.

                                                     

                                                    As a last resort I tried running my game with your .ini file, and was unable to replicate the mountain flickering (other stuff did return, but not the flickering you posted).

                                                    So since I can't replicate the problem, I cannot attempt to fix it.

                                                     

                                                    I'm sorry I don't have better news for you, and thank you for posting the .ini.

                                          • Re: Witcher 3 Crossfire Flickering Fix!!!
                                            dutcher_butcher

                                            Ok guys I think I found the last piece of the puzzle.

                                             

                                            The only other thing I could try to get rid of the last bit of stutter worked.

                                             

                                            MEGA

                                             

                                            The above link houses a bunch of .dll files from different AMD drivers.

                                            These seem to be made for W10, and the newer r9 3xx series.

                                             

                                            Download the 1023.0, 1036 or 1038 ones.

                                            1023.0 seems to be the best for fps gains, but that could just be my system.

                                            I mention the others since they're known to also work with Witcher 3, no guarantee the latter will fix the flickering though I only tested 1023.0.

                                            And if it ain't broke why fix it right?

                                             

                                            Just copy the .dll files into your Witcher 3/bin/x64 folder (where the .exe is located).

                                            And run the game with all the fixes above applied via Radeonpro.

                                            If you're running at higher resolutions it might be a good idea to set the File Queue Size to something like 1 or 2 as stuttering may be introduced otherwise.

                                             

                                            If you still have stuttering after this fix just go here: Witcher 3 Stuttering Fix!!!

                                             

                                            For the original thread go here: AMD Driver DLLs Repository and Performance Survey - Guru3D.com Forums

                                             

                                            This fix does not change the base driver or CCC version, it only affects the game, and can be undone by deleting the .dll's in question.

                                            So it might be a good idea to write their names down before placing them.

                                             

                                            Tested this with 2x 280x/fx8350 (at 4.3ghz)/32 gigs ram/Beta 15.6 driver/patch 1.06/W7 x64 Ultimate.

                                             

                                            Why these drivers are only available to newer gcn card owners on W10 I will never know.

                                             

                                            If you happen to try the 1036 or 1038 drivers and get good/bad results, please leave a comment below with you GPU/CPU info.

                                            That way people with different hardware know which drivers to implement.

                                            • Re: Witcher 3 Crossfire Flickering Fix!!!
                                              thehairyfoot

                                              I have noticed quite a bit of improvement with 1.07 patch, vanilla settings on all ini files too.

                                              Not all of it is gone; I've only visited briefly some of the places which used to be affected the worst, but it seems to be pretty playable now.
                                              Still need AA off though I'll post if I find a nice work around for that

                                               

                                              EDIT: On playing through for an hour or more, I don't think the results were anything I thought they might be: it still has major issues at certain times of day. Looks like I'm back to single GPU for now and 30 FPS...

                                              1 of 1 people found this helpful
                                                • Re: Witcher 3 Crossfire Flickering Fix!!!
                                                  mrfury

                                                  I don't think the 1.07 patch has been released yet.  I noticed a large patch released today, but unfortunately it was just a art pack.

                                                  1 of 1 people found this helpful
                                                  • Re: Witcher 3 Crossfire Flickering Fix!!!
                                                    Cornugon

                                                    The water is still crap and flat.

                                                     

                                                    And for some reason, pumping the res up to 3200x1800 with all settings maxed hard crashes my rig with loosing the video signal (was the same with the 15.5's). The secondary GPU's fan also spins up to maximum while getting this, even though it usually remains around 50% in other games (and 95% usage).

                                                    I've tried to see if it's a system instability/hardware issue, but it doesn't happen with GTA V (seems to run perfectly now!) or 3D Mark Firestrike Extreme testing.

                                                     

                                                    EDIT: Apparently the crashing was on my end though. There seems to be issues with a Hasswell-E platform and RAM speeds of higher than 2133MHz and/or XMP. Having both reapplied the thermal paste on my secondary card, and tampered a bit with the RAM-speeds it 'seems' fine (for now).

                                                     

                                                    Back on topic: the stuttering is still there though when on 3200x1800 res and/or Hairworks enabled. It SEEMS less, and on top of it all, the in-game AA setting doesn't appear to negatively affect performance now (which is a plus).

                                                    1 of 1 people found this helpful
                                                    • Re: Witcher 3 Crossfire Flickering Fix!!!
                                                      dutcher_butcher

                                                      1.07 isn't released yet, there was however a 2.2gig language pack patch but they didn't give it a number since it didn't fix anything.

                                                      Beta 15.7 fixes the flickering, and you can use the previous method through RadeonPro (flip queue size) to get rid of the stuttering.

                                                      The stuttering fix still aplies with 15.7 beta, see below for the instructions.

                                                       

                                                      Witcher 3 Stuttering Fix!!!

                                                    • Re: Witcher 3 Crossfire Flickering Fix!!!
                                                      thehairyfoot

                                                      15.7 drivers seems to have fixed it for real this time

                                                      2 of 2 people found this helpful
                                                        • Re: Witcher 3 Crossfire Flickering Fix!!!
                                                          amdmatt

                                                          7fa_zps5046c758.GIF

                                                          1 of 1 people found this helpful
                                                          • Re: Witcher 3 Crossfire Flickering Fix!!!
                                                            Cornugon

                                                            It does appear to have fixed the flickering indeed!

                                                             

                                                            Now that just leaves the missing wavy water tesselation (including the broken water effects while swimming), and the stutter at 3K+ resolutions (which seems to have improved a bit though!).

                                                             

                                                            But at least the in-game (Temporal) AA now works using CFX!

                                                             

                                                            EDIT: It appears I was mistaken about one thing: The wavy water looks just as fine as on single-GPU.

                                                             

                                                            With a more extensive period of testing I've come to the following findings, compared to the 15.5 bèta's:

                                                             

                                                            These problems still remain:

                                                            -Stuttering mostly while in motion (more stuttering than single GPU. The higher the settings the more stuttering, even when the framerate remains 'playable' between 50-60fps)

                                                            -Broken water animations while swimming and sailing.

                                                            -flickering 'icons' on 2D-screens (inventory/character screens, while playing gwent, on the world map.)

                                                             

                                                            And these appear to have been fixed:

                                                            -Flickering textures

                                                            -The in-game MLAA+TAA while using CFX.

                                                             

                                                            Here's waiting until CDPR decides to release the next patch which hopefully comes with additional fixes. For some reason they decide hold off the PC version to wait this time around until the Xbone and PS4 versions are certified...always a bucketload of crap in my opinion...

                                                             

                                                            On a side note: I also checked GTA V for a bit and that one ran better than ever!

                                                            3 of 3 people found this helpful
                                                            • Re: Witcher 3 Crossfire Flickering Fix!!!
                                                              mrfury

                                                              OMG, it is like playing a brand new game.  Once patch 1.7 comes out I may have to start over, to get the full experience.

                                                              1 of 1 people found this helpful
                                                                • Re: Witcher 3 Crossfire Flickering Fix!!!
                                                                  fug222

                                                                  This is really sickening. I had a 290x Crossfire set up which i sold on Monday for 500 euro. Bought my self a 980ti so i could play the Witcher 3 which cost me 290 euro on top of the 500 just to play the Witcher at 1440p ultra. now AMD has decided to fix an issue they have said was due to CD Projekt RED coding of the witcher 3, Crossfire flicker which would have to be fixed on CD Projekt RED end. You know i am glad i got rid of the cards after all of AMDs lies. cost me a lot of money for less performance but at least i can play the game now.

                                                                    • Re: Witcher 3 Crossfire Flickering Fix!!!
                                                                      electricessence

                                                                      I have a mix of AMD cards and one nVidia 780ti on a 1080p TV and I'd have to say that nVidia has its issues too!

                                                                       

                                                                      Current state of things:

                                                                      AMD) Single cards have really smooth frames but lack tessellation power compared to nVidia so if you value HairWorks you'll take a hit on FPS and still may need to degrade tessellation to maximum of 16x which also affects terrain quality. Crossfire is at about 95% quality level of 1 card with decent scaling.  Room for improvement.  It took AMD about 6+ weeks to release a playable beta driver for Crossfire.

                                                                      NVIDIA) Significant and common crash reports.  Very common "popping" of models into view.  If you played on an AMD system its distinctly obvious as NPCs just appear in front of you out of nowhere.  Less smooth frames.  I found my nVidia 780ti performing equally or worse overall than my 290x (without HairWorks) but the nVidia card/driver was more prone to stuttering and surging.  The weird inconsistent frame surging wasn't fixed by setting a frame target and for me is an uncomfortable feeling and if I cant ignore it I dont want to play on that system.  To be fair, Crossfire 290xs show this behavior slightly but not often.

                                                                      1 of 1 people found this helpful
                                                                • Re: Witcher 3 Crossfire Flickering Fix!!!
                                                                  wildcard84

                                                                  Amazing ! the fix worked perfectly. You got my solute sir !

                                                                  I'm running i5 4670 / Sapphire HD7970 OC x2 / Benq XL2420Z x 3 Monitors (144Hz refresh rate)

                                                                  I find most games smooth if the framerate is above 60 and with Vsync Off, because at 144Hz all frames generated automatically get synced to the monitor refresh rate as I've observed. 30 FPS feels quite unsmooth to me personally. For extra performance in resorce intensive games like Witcher 3 I go with only one screen in full screen at 1080p mostly.

                                                                  1 of 1 people found this helpful
                                                                  • Re: Witcher 3 Crossfire Flickering Fix!!!
                                                                    dutcher_butcher

                                                                    Well beta 15.7 seems to have fixed it with Vanilla settings, we still need to use CCC to apply a non jittery AA though.

                                                                     

                                                                    But now for some reason my crossbow refuses to work, it's as if the tilde key isn't bound to it, there is also no option in the key bindings.

                                                                    Does this game auto update??? Cause I haven't installed anything new, I also got a message saying my old saves wouldn't work with this version!???

                                                                    Still that's not nearly as bad a bug as a flickery game.

                                                                     

                                                                    Nice job AMD...+1 to your driver team.

                                                                     

                                                                    EDIT: Fixed it you have to rebind the keys to not only the bombs but rebind the crossbow to something like tilde.

                                                                    The standard button for crossbow is middle mouse button, but many mouse types aren't fully supported so it doesn't work.

                                                                    Just unbind, then rebind the bombs, and then rebind the crossbow to something on the keyboard not the mouse.

                                                                      • Re: Witcher 3 Crossfire Flickering Fix!!!
                                                                        electricessence

                                                                        So I just tested the game with the new driver using "Default Mode" for Crossfire.

                                                                         

                                                                        Facts:

                                                                        1)  Major flickering is gone.  No super annoying puddle flashes or weird mountain textures changing, etc.
                                                                        2)  Anti-aliasing is still an issue and could use some work.  With it on, it flickers the edges of objects.  This can be solved with Radeon Pro I think.  But haven't tested that.
                                                                        3)  Still flickers on sprites and sprite effects like Gwent Cards and Map Icons.

                                                                        4)  Performance is great!  Scaling well.  Even with Hairworks.  Will be nice to see how 1.07 fixes things.

                                                                         

                                                                        An interesting suggestion for everyone:
                                                                        Try underclocking card 1 and overclocking card 2.  I found that my frames were still stable but my temps were a lot more balanced and the fans were quieter.

                                                                         

                                                                        At this point, as far as my understanding goes, the rest may actually be a game development problem.  And I'm not mad at AMD anymore.

                                                                        1 of 1 people found this helpful
                                                                      • Re: Witcher 3 Crossfire Flickering Fix!!!
                                                                        sotodeshi

                                                                        Bummer, bummer, bummer!!! Patch 1.07 ruined everything for me (flickerwise). Im running 2x Radeon 7770hd. on the newest catalyst driver (15.7). After applying fixes from this thread everything was going smoothly for me and now after the latest patch IT FLICKERS LIKE NEVER BEFORE!!! It freekin sucks! anyone has the same problem! any clues?

                                                                        1 of 1 people found this helpful
                                                                          • Re: Witcher 3 Crossfire Flickering Fix!!!
                                                                            dutcher_butcher

                                                                            Yep same here, but 280x'es.

                                                                             

                                                                            Stutter is waaaaaay worse, and I get flickering inside caves only for some reason.

                                                                            Also all the cave entrances are now texture mapped and no longer invisible....WTF?

                                                                            Oh and only from the outside, someone forgot to check the '2-sided alpha texture checkbox'.

                                                                             

                                                                            Roach is worse, and randomly just drops below the horizon (even when I'm on him) and I have to reload as Geralt get's stuck with his legs buried in the ground.

                                                                            I would have uploaded a video since that was kinda funny, but since 1.07 I can't use any 3rd party video recording software without a hard crash.

                                                                            Even simple fps counters like fraps or afterburner make it hard crash for me, which also prevents me me from finding the ideal settings atm as I've no clue what my fps is.

                                                                             

                                                                            He also spawned inside of random stuff allot like barrels and fences, granted he did that before but not nearly as much.

                                                                            I'd rather have a face planting roach than a roach I can't ride at all ever.

                                                                            BTW this naturally makes some scripted missions impossible to complete.

                                                                             

                                                                            I'm also getting random crashes now whenever I fast travel to Skellige from somewhere else, but not when traveling from inside Skellige itself!?

                                                                            They said they fixed the streaming issues in the patch notes but it seems to have gotten worse, I used to be able to play somewhat smoothly at 30fps lock but now even that's not possible, and the pop-in has gotten worse.

                                                                             

                                                                            The grass popping! God the grass popping, how did they manage to make this worse?

                                                                            Wasn't that just a timing issue? (talking about xfire obviously. e.g. one frame grass the other none)

                                                                             

                                                                            Unfortunately I can't even begin to troubleshoot, as I don't have a reliable fps counter working.

                                                                            Not that I would though, this patch seriously messed with allot of stuff that was working fine before.

                                                                             

                                                                            They held it back because of the consoles, so why couldn't they test this in the meantime???

                                                                             

                                                                            For me at least this patch breaks the game to 'Unity' levels, and that's saying something.

                                                                            I can't stress enough how it manages to break soooo many things, I'm sure I've left a bunch of stuff out.

                                                                             

                                                                            Re-installing didn't do anything, and neither did starting a new save.

                                                                            I'm not saying the inventory fixes aren't a good addition, but they're utterly useless if I can't play the game properly to begin with.

                                                                             

                                                                            Maybe I'll return to this game ( and attempt to fix possible issues ) if/when another patch comes out.

                                                                            But until then I'm shelving it, I'll play something else instead.

                                                                             

                                                                            Well done CDPR...Well Done...*Sigh*

                                                                             

                                                                            Edit:Retaking ownership of the Witcher 3 install folder seems to have solved most of my problems.

                                                                             

                                                                                   Roach is still messed up, as are the cave entrances, and I'm getting grass popping on any setting higher than low.

                                                                                   The stuttering is also still pretty bad, but the flickering in the caves is gone.

                                                                             

                                                                                   I could go back to 1.06 to get rid of the grass popping somewhat, but then I won't have the new additions to the inventory.

                                                                                   The stash is pretty nice, but the best addition was the read/unread function.

                                                                                   BTW if you still can't find a note/book you need to read, check both the quest items tab and the books tab, they don't always end up under the quest tab by default.

                                                                             

                                                                                   Anyway...slowly getting there again, but still pretty miffed about not being able to run an fps counter, every time I do the game either freezes or my gpu's stop responding (hard crash).

                                                                             

                                                                                   My wishes for 1.08 are, a built in fps counter, Alternative AA (e.g. smaa/msaa) I'm getting kinda sick of FXAA, and significant stutter fixes throughout the game.

                                                                                   I realize some areas will never have good fps, but moving 2 feet in a field almost devoid of people, buildings and trees should not drop my fps by 20.

                                                                            1 of 1 people found this helpful
                                                                              • Re: Witcher 3 Crossfire Flickering Fix!!!
                                                                                ucouldbrong

                                                                                Hmm...was actually going to get this game today, but it may be better to wait until it goes on sale.

                                                                                 

                                                                                These are some of the efforts I wish complainers would attempt.  Thanks for your diligence in seeking solutions.

                                                                                 

                                                                                 

                                                                                • Re: Witcher 3 Crossfire Flickering Fix!!!
                                                                                  Cornugon

                                                                                  The 1.07 didn’t break/make the game worse for me. I was affected by these occasional solid entrance textures-issues even before 1.07, but there’s no flickering here. Strange... Maybe clearing out the cache directory could help?

                                                                                    • Re: Witcher 3 Crossfire Flickering Fix!!!
                                                                                      electricessence

                                                                                      I'd have to agree.  After the latest beta driver update, I haven't had any issues.  And with 1.07, anti-aliasing seems to work perfectly.

                                                                                       

                                                                                      At this point, if I didn't know there was ever anything wrong, I wouldn't know there was a real problem.


                                                                                      Still remaining:
                                                                                      Some sprite flickering.  That's it.

                                                                                        • Re: Witcher 3 Crossfire Flickering Fix!!!
                                                                                          dutcher_butcher

                                                                                          Are either of you perhaps on Windows 8/.1 or 10?

                                                                                           

                                                                                          I'm on W7 x64 Ultimate, Yesterday I even tried a new OS install and the above problems still persist.

                                                                                          That's with a new game install and savegame...obviously.

                                                                                           

                                                                                          Or perhaps it could be because of the factory overclock on my gpu's, although even that wouldn't explain the roach behaviour.

                                                                                          And I've already tried clocking them down to reference speeds.

                                                                                           

                                                                                          I've also checked both bios versions are the same on my gpu's, as well as checking the PCI mode is running at 2.0 when the game is running.

                                                                                          No power saving options are enabled, and my PSU is 1200 Watts. Everything is connected with full 8-pin connectors, not 6+2.

                                                                                          Each rail (x4) has also been given it's own cable, so no amperage problems there either.

                                                                                          Also both gpu's are the same exact model.

                                                                                           

                                                                                          I've also checked the run-times were up to date, and there has not been a windows update since 1.06.

                                                                                          Mobo bios is also updated.

                                                                                           

                                                                                          Anyway I'm glad it's working well for you guys, but for me it's nowhere near finished yet.

                                                                                          All the problems I mentioned above are still present for me.

                                                                                            • Re: Witcher 3 Crossfire Flickering Fix!!!
                                                                                              Cornugon

                                                                                              I'm on Win 8.1 here. I already had CFX stuttering issues before 1.07 or catalyst 15.7. But it didn't get worse since 1.07 (nor better). I don't have flickering issues, that was fixed for me in the 15.7 drivers.

                                                                                               

                                                                                              In short the graphical/performance issues I still am affected by:

                                                                                              -more stutter with Crossfire enabled even though having double the fps.

                                                                                              -broken water animations while interacting with it.

                                                                                              -occasional walls where a (cave) entrance should be.

                                                                                               

                                                                                              EDIT: On a side note: 1.07 apparently broke achievements unlocking, and seems to affect both Steam and GoG versions. This is definitely not AMD's problem though

                                                                                              1 of 1 people found this helpful
                                                                                              • Re: Witcher 3 Crossfire Flickering Fix!!!
                                                                                                sotodeshi

                                                                                                Im on W7 x64, File verification from gog didnt do anything. To be honest i didnt noticed any change going from soft 15.6 to 15.7. Cascade shadow distance scale line + queue size 0 in radeon pro did the trick for me - that is very rare flickering (i dont observe much stuttering back then and now). But now since the 1.07 patch the flickering is unberable and previous fixes dont work. A guy from CDPR techsupport told me to make a clean install, he wrote "conflicts of some dll-s may cause textures flickering". But that should be dealt with after files verification right?

                                                                                                 

                                                                                                edit: Im currently talking with CDPR techsupport worker. Were trying different things. Ill let you guys know if there will be any results.

                                                                                                 

                                                                                                edit 2: Ok so we did couple of rutine checks, ive sent the guy a video link with whats happening in my case (Mój film - YouTube ) and I was adviced to use underneath dynamic shadow settings:

                                                                                                 

                                                                                                CascadeShadowDistanceScale0=1.5

                                                                                                CascadeShadowDistanceScale1=3.0

                                                                                                CascadeShadowDistanceScale2=2.5

                                                                                                CascadeShadowDistanceScale3=2.0

                                                                                                 

                                                                                                He also recomended me watching this video: (How To Optimize The Witcher 3 For AMD Radeon Cards [CrossFire] - 1080p 60fps PC Max Settings - YouTube ) and to read this nvidia thread:

                                                                                                The Witcher 3: Wild Hunt Graphics, Performance & Tweaking Guide | GeForce

                                                                                                 

                                                                                                Didnt help me (although they are still analising my dxdiag). Meaby it will do some good for you guys.

                                                                                                1 of 1 people found this helpful
                                                                                                  • Re: Witcher 3 Crossfire Flickering Fix!!!
                                                                                                    dutcher_butcher

                                                                                                    Cool and thx for replying.

                                                                                                     

                                                                                                    Verification didn't do anything for me either, also did a DDU.

                                                                                                    I even tried a completely clean system with new OS and game install.

                                                                                                     

                                                                                                    Another symptom has popped up as well.

                                                                                                    Whenever I try and dive I can't, this happens mostly in Skellige at the smuggler's caches that are furthest away from land.

                                                                                                    That's also where the water effects stop working.

                                                                                                     

                                                                                                    Anyway so far that's 2 people running W7 with major problems, and 1 with 8.1 with stuttering but no flickering.

                                                                                                    Maybe we're on to something here?

                                                                                                      • Re: Witcher 3 Crossfire Flickering Fix!!!
                                                                                                        salvolin

                                                                                                        I started playing the Witcher 3 somewhere early june. I had the flickering issue too. Went on vacation and when I came back AMD had it's drivers at 15.7 and the game was on 1.07.

                                                                                                        With those versions everything works fine for me. I did have to de install the beta AMD drivers before installing the 15.7 normal version. Installing 15.7 over the beta driver didn't work for me.

                                                                                                         

                                                                                                        I am on a W8.1 laptop with crossfire AMD R9 m290x and a i7 processor.

                                                                                                        My only issue is that with AA off, Hairworks Off and the game on Ultra (1920x1080) I only get around 24 FPS (afterburner works perfectly for me, both GPU work at >95%) .

                                                                                                         

                                                                                                        I started studying this thread to seek any performance tweaks. Hopefully I'll there is still room for improvement for me. I don't have much time to play so I am still in Velen!

                                                                                                          • Re: Witcher 3 Crossfire Flickering Fix!!!
                                                                                                            dutcher_butcher

                                                                                                            Hi,

                                                                                                             

                                                                                                            The biggest fps hits are these in order.

                                                                                                             

                                                                                                            1.HBAO vs SSAO (set to SSAO for better fps)

                                                                                                            2.Shadows try these at medium or high (from Ultra to High gave me ca. 15 fps)

                                                                                                            3.Grass Density try medium or high (this isn't just grass it also affects the quality of shrubs and small trees etc.)

                                                                                                             

                                                                                                            edit: (ty Cornugon)

                                                                                                            4.Foliage Distance Scale (makes a massive difference at higher resolutions)

                                                                                                             

                                                                                                            Also anything with lots of tessellation like hairworks or water makes a big difference as well.

                                                                                                             

                                                                                                            Hope it helps

                                                                                                             

                                                                                                            P.S. I didn't realize there's a certified version of 15.7 now, I'll have to check that out.

                                                                                                            Thanks for the info.

                                                                                                             

                                                                                                            edit:never mind it's the same driver as the beta.

                                                                                                              • Re: Witcher 3 Crossfire Flickering Fix!!!
                                                                                                                Cornugon

                                                                                                                Don’t forget Foliage Visibility Range! The Ultra setting has quite a big impact vs the High setting.

                                                                                                                1 of 1 people found this helpful
                                                                                                                  • Re: Witcher 3 Crossfire Flickering Fix!!!
                                                                                                                    salvolin

                                                                                                                    Thanks for the tips

                                                                                                                     

                                                                                                                    Since I am at home now I tweaked a bit with it. For reference info I'll also post my system cinfig

                                                                                                                    W8.1 64 bit

                                                                                                                    Witcher 3 through Origin

                                                                                                                    16 GB Ram

                                                                                                                    Intel core i7-4800MQ

                                                                                                                    AMD R9 m290x Crossfire

                                                                                                                     

                                                                                                                    With everything on Ultra execpt AA, HAirworks and SSAO, and standing still  (these test are performed in order, so I didn't set any settings back to ultra or high after setting it to high or medium)

                                                                                                                    23,9 FPS when I set Foliage visibility to HIGH

                                                                                                                    24,7 FPS when I set Foliage visibility to Medium

                                                                                                                    25,3 FPS when I set shadows to high 

                                                                                                                    25,8 FPS when I set shadows to med

                                                                                                                    26,0 FPS when I set grass to high

                                                                                                                    26,1 FPS when I set grass to med

                                                                                                                     

                                                                                                                    Overall not much of a difference. Both GPU's where on 98% or 99% CPU was under 40%, memory usage around 5GB

                                                                                                                     

                                                                                                                    May I expect more?

                                                                                                                    1 of 1 people found this helpful
                                                                                                                      • Re: Witcher 3 Crossfire Flickering Fix!!!
                                                                                                                        dutcher_butcher

                                                                                                                        I doubt it since it's a micro-gpu, but what's you're resolution.

                                                                                                                        And are you by chance using VSR?

                                                                                                                         

                                                                                                                        It would seem the tweaks don't make enough of an impact for you, so turning down the resolution could be an option.

                                                                                                                        Also make sure you're laptop isn't running in power saving mode.

                                                                                                                          • Re: Witcher 3 Crossfire Flickering Fix!!!
                                                                                                                            salvolin

                                                                                                                            I am playing at 1920 x 1080

                                                                                                                             

                                                                                                                            I wanted to check CCC to see if I could adjust some more settings there. Starting CCC gave me an error message.

                                                                                                                            So I decided to remome and re install my catalyst drivers once more. Than I removed the witcher3.exe profile in CCC.

                                                                                                                             

                                                                                                                            Funny thing is that Afterburner now sees my GPU as a HD8970M (which according to internet is basically the same card)

                                                                                                                            But the best thing yet  ... with everthing on Ultra, and AA off (and SSAO) I get 40 FPS

                                                                                                                            I set foilage visibility from Ultra to high and AA on in the game menu itself.

                                                                                                                             

                                                                                                                            Result a nice 50 FPS. Thanks for the help here, I am now going to enjoy the game so more!!

                                                                                                                             

                                                                                                                            EDIT:

                                                                                                                            p.s. I might be experiencing an occasional stutter now. But I see you have a post on that. Will check that out later on.

                                                                                                                            1 of 1 people found this helpful
                                                                                                                          • Re: Witcher 3 Crossfire Flickering Fix!!!
                                                                                                                            dutcher_butcher

                                                                                                                            Also forgot to mention something.

                                                                                                                             

                                                                                                                            You can edit the fps limiter in user.settings (My Documents/Witcher 3)

                                                                                                                            Set it to the lowest fps to ensure the stuttering disappears.

                                                                                                                            If I were you I'd tweak the settings so you get 25 fps at the least (settings 3-4-5 or 6, from the ones you mentioned).

                                                                                                                             

                                                                                                                            It'll be a bit of a slideshow, but it will be smooth at least.

                                                                                                                             

                                                                                                                            P.S. what fps counter did you use?

                                                                                                                            • Re: Witcher 3 Crossfire Flickering Fix!!!
                                                                                                                              mrfury

                                                                                                                              Yeah, I think you are asking too much of a mobile GPU for this game for 4k.  I would take it down to 1080p.  I am using a lesser Crossfire config (2 HD7970m) and I am getting a solid 50-60fps at 1080P.

                                                                                                                              1 of 1 people found this helpful
                                                                                                                                • Re: Witcher 3 Crossfire Flickering Fix!!!
                                                                                                                                  salvolin

                                                                                                                                  Hey Guys,

                                                                                                                                   

                                                                                                                                  My previous is reaction is still being moderated (for over a day now) so sorry for my late reaction.

                                                                                                                                  I am playing 1920 x 1080 and with the AMD drivers freshly installed once more I do get my 40+ FPS with all ultra.

                                                                                                                                  I even tried hairworks, but I think Gerald looks better without it...

                                                                                                                                   

                                                                                                                                  I do still have an occasional glitter when I read witcher contracts or check the inventory.

                                                                                                                                   

                                                                                                                                  Regards,

                                                                                                                                  Salvolin

                                                                                                                                   

                                                                                                                                  p.s. Hope I will be trusted to leave direct replies soon, so there won't be any delays anymore. Thanks for all the help.

                                                                                                                                   

                                                                                                                                  Edit: I am using msi afterburner to check my fps

                                                                                                                                  1 of 1 people found this helpful
                                                                                                          • Re: Witcher 3 Crossfire Flickering Fix!!!
                                                                                                            biggun1460

                                                                                                            This did not work for me I still have flickering at a distance. I haven't fully tested it yet but the flickering still remains especially at a distance (mountains).

                                                                                                            Resolution 3860x2160

                                                                                                            GPU's 2 R9 Fury X UEFI bios  in crossfire.  

                                                                                                            CPU 3960X OC to 4.0GHZ 3.5V   

                                                                                                            RAM 16 Gigs 4x4Gigs at 2100 9-10-11-27 1.5V

                                                                                                            OS Windows 10 1803

                                                                                                            Post processing and AA enabled no Vertical Synce and Ultra for all settings except Nvidia hairworks.