AnsweredAssumed Answered

Installing fglrx-core_15.101-0ubuntu1_amd64

Question asked by ameetgandhare on Jun 4, 2015
Latest reply on Jun 5, 2015 by nou

Hi All,

 

I am trying to install the AMD Catalyst driver v15.5 available at

Desktop

As the site describes, it is a AMD Catalyst™ 15.5 Proprietary Ubuntu 14.04 x86_64 Minimal Video Driver for Graphics Accelerators (Non-X Support)

As I want to setup OpenCL configuration without X Server installation on a Ubuntu.

when I run the command $dpkg -i Installing fglrx-core_15.101-0ubuntu1_amd64

It saves this error in the error log.

>>><<<

DKMS make.log for fglrx-core-15.101 for kernel 4.0.0 (x86_64)

Thu Jun  4 13:32:23 IST 2015

/usr/sbin/dkms: line 73: cd: /var/lib/dkms/fglrx/15.101/build: No such file or directory

AMD kernel module generator version 2.1

doing Makefile based build for kernel 2.6.x and higher

rm -rf *.c *.h *.o *.ko *.a .??* *.symvers

make -C /lib/modules/4.0.0/build SUBDIRS=/var/lib/dkms/fglrx-core/15.101/build/2.6.x modules

make[1]: Entering directory `/root/Code/build_linux-4.0'

  CC [M]  /var/lib/dkms/fglrx-core/15.101/build/2.6.x/firegl_public.o

/var/lib/dkms/fglrx-core/15.101/build/2.6.x/firegl_public.c: In function ‘kcl_mem_pat_setup’:

/var/lib/dkms/fglrx-core/15.101/build/2.6.x/firegl_public.c:4471:9: error: implicit declaration of function ‘read_cr4’ [-Werror=implicit-function-declaration]

         cr4 = read_cr4();

         ^

/var/lib/dkms/fglrx-core/15.101/build/2.6.x/firegl_public.c:4472:9: error: implicit declaration of function ‘write_cr4’ [-Werror=implicit-function-declaration]

         write_cr4(cr4 & ~X86_CR4_PGE);

         ^

/var/lib/dkms/fglrx-core/15.101/build/2.6.x/firegl_public.c: In function ‘kasSetExecutionLevel’:

/var/lib/dkms/fglrx-core/15.101/build/2.6.x/firegl_public.c:4819:5: error: implicit declaration of function ‘__get_cpu_var’ [-Werror=implicit-function-declaration]

     orig_level = __get_cpu_var(kasExecutionLevel);

     ^

/var/lib/dkms/fglrx-core/15.101/build/2.6.x/firegl_public.c:4820:38: error: lvalue required as left operand of assignment

     __get_cpu_var(kasExecutionLevel) = level;

                                      ^

/var/lib/dkms/fglrx-core/15.101/build/2.6.x/firegl_public.c: At top level:

/var/lib/dkms/fglrx-core/15.101/build/2.6.x/firegl_public.c:6396:12: warning: ‘KCL_fpu_save_init’ defined but not used [-Wunused-function]

static int KCL_fpu_save_init(struct task_struct *tsk)

            ^

cc1: some warnings being treated as errors

make[4]: *** [/var/lib/dkms/fglrx-core/15.101/build/2.6.x/firegl_public.o] Error 1

make[3]: *** [_module_/var/lib/dkms/fglrx-core/15.101/build/2.6.x] Error 2

make[2]: *** [sub-make] Error 2

make[1]: *** [__sub-make] Error 2

make[1]: Leaving directory `/root/Code/build_linux-4.0'

make: *** [kmod_build] Error 2

build failed with return value 2

 

 

Kindly help me fix the error and get the driver running.

 

Regards,

Ameet

Outcomes