0 Replies Latest reply on Jun 2, 2015 8:10 PM by loldragon

    "No supported AMD hardware was detected" error when trying to install Catalyst driver

    loldragon

      For many months now, I've been unable to completely update the drivers in my AMD Radeon HD 6970M graphics card installed into my 2011 27" iMac. I run games on my Mac through Bootcamp, so I run Windows 7 (64 bit) on it for that, and for the past 4 years I've had relatively few problems updating my drivers. However, since around the time GTA V came out in the middle of April, I can't install the latest drivers onto my card.

       

      Here's what happens: once I download the driver, I'll double click on (in this case the file is AMD-Catalyst-15.4Beta-64BitWin7-Apr9.exe), tell it to install to the default destination, then it'll show a loading bar and... *error tone*, all I get is an error window that says, "We are unable to find a driver for your system. No supported AMD hardware was detected."

       

      These issues persisted after I recently gave my computer a clean installation of Windows 7. While I was able to install myself up to Catalyst 14.12 (I first had to install an old Catalyst 13.9 driver I held on to), I can't seem to get Catalyst 15.4 or I believe anything after that installed because of this peculiar "no supported AMD hardware was detected" window.

       

      Maybe it's worth noting that a few months ago I had a new GPU reinstalled into my computer (the exact same make and model) because the old one died, but everything else about my GPU has been functioning just fine, and the new one was installed by a licensed service provider at a local TD Curran, so I don't know if that's relevant to this issue or not. Maybe a red herring?

       

      Any help would be appreciated. Thank you in advance!