AnsweredAssumed Answered

STRANGE AMD HDMI ISSUE

Question asked by sean797 on Jun 1, 2015
Latest reply on Jun 2, 2015 by iwalkwithedead

So a couple of days ago I turn on my pc after not powering it on for a week and I notice my main screen is not working.

 

Turns out my card was not outputting a HDMI signal anymore. (Only VGA works)

 

So over the last 2 weeks I have tried everything in the book....

 

  • Fresh Installed Windows
  • Updated Latest Drivers
  • Tried monitor with other HDMI devices/screens (works just fine, using the same HDMI cable)
  • Pulled card out, reseated everything, made sure everything is connected correctly
  • Checked BIOS, BIOS is fine.
  • Power cycled everything a dozen times

 

Now here is where it gets weird

  • I pulled out the card and tried an older AMD card (VGA worked, HDMI didn't work on that card either (SAME EXACT ISSUE)
  • I put in an old Nvidia card (VOILA!!! HDMI is working!)

 

I honestly have no clue what's going on here, I'm pretty good with computers, fixing software issues has never been a problem for me, but I seriously can't wrap my head around this.

My Nvidia card is outputting HDMI just fine, but neither of my AMD cards are.

I've tried different drivers and nothing works, I can't find this problem anywhere else on the internet, seriously I tried, I've been obsessing over this for 2 weeks and I'm close to giving up.

 

 

This is my System

AMD FX 8350 (8 x 4.0 GHZ)

Gigabyte 970A-DS3P (AMD 970)

AMD Radeon HD 7950 - 3 GB - (XFX)

Corsair 8GB XMS3 PC3-12800 1600MHz (1x8GB)

120GB Kingston SSD

1 TB Seagate (1000 GB) HDD 7200 RPM

 

Monitor: BENQ GL2450

Outcomes