AnsweredAssumed Answered

CodeXLAnalyzer fails building for OpenCL2.0 compliant devices when only available online non-OpenCL 2.0 device

Question asked by matszpk on May 29, 2015
Latest reply on Jul 10, 2015 by matszpk

Hi, I tried to compile with using CodeXLAnalyzer simple OpenCL code using OpenCL 2.0 standard for an OpenCL2.0 compliant device (for example Hawaii). I have only Radeon HD 7850 (OpenCL 1.2 compliant device) and that program returns following error after failed compilation:

 

AMD Catalyst detected, version 14.501.1003

Compiling device: Tonga... ...Failed!

OpenCL Compile Error: clBuildProgram failed (CL_BUILD_PROGRAM_FAILURE).

An invalid option was specified.

 

--------

 

I ran CodeXLAnalyzer with options:

./CodeXLAnalyzer --bin localtest1 --OpenCLoption="-cl-std=CL2.0" -c Hawaii localtest1.cl

 

localtest1.cl is sample OpenCL 1.2 code (can be build on OpenCL 1.2 devices).

My platform is: OpenSUSE Linux (64-bit), Amd drivers: 14.12 (omega).

I guess that is problem with AMD Catalyst drivers. I will be happy, if this problem will be resolved in near future.

Outcomes